
Введение 

Данные методические указания описывают процесс проектирования 
адаптивных СЗИ на основе экспертных систем (ЭС), нечеткой логики (НЛ),  
нейронных (НС) и нейро-нечетких (ННС) сетей. 

В первой части методических указаний содержится описание  
общетеоретических положений по организации адаптивных систем 
информационной безопасности с использованием интеллектуальных средств и 
программной диалоговой среды RulesEditor  - редактора нечетких 
продукционных правил, позволяющей сформировать базу знаний эксперта ИБ в 
виде системы нечетких продукционных правил и отразить базу знаний в 
структуре ННС. 

Материал, содержащийся во второй части методических указаний, 
продолжает знакомство с многоцелевой программной средой «Neuro-Fuzzy», а 
именно: с программной  интерактивной средой NeuralNetworkBuilder, 
позволяющей осуществлять формирование и коррекцию топологии НС и ННС, 
а также с программной  интерактивной средой Forecast для исследования 
процессов адаптации информационных полей нейронных и нейро-нечетких 
сетей. Программная среда «Neuro-Fuzzy» разработана при участии студентов 
каф. БИТ Доскача В. О., Инюшина И. М. и Леонтьева Р. В. 

1. Практическая часть 

Формирование и коррекция топологии НС может выполняться в 
программной  интерактивной среде NeuralNetworkBuilder. 

1.1. Neural Network Builder  

Программный модуль NeuralNetworkBuilder позволяет выполнять 
следующие операции: 

 создание новой нейронной сети; 
 редактирование арифметической нейронной сети; 
 редактирование логической (нейронечеткой) нейронной сети; 
 редактирование квазилогической нейронной сети; 
 открытие старого проекта; 
 закрытие проекта; 
 быстрое сохранение проекта; 
 сохранение проекта под именем; 
 автоматическая расстановка нейронов; 
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 автоматическая проверка на ошибки; 
 добавление в проект информации о себе; 
 именование входного и выходного слоя. 

Создание нейронной сети 

Для создания топологии нейронной сети следует выбрать опцию меню 
Project->Create (рис.1). В открывшемся окне отметьте один из трех типов 
нейронных сетей, которые поддерживает NeuralNetworkBuilder: 

 Basic Neural Network – арифметическая НС, 
 Fuzzy Neural Network - логическая (нейро-нечеткая) сеть, 
 Quazy Neural Network – квазилогическая НС. 

 
Рис. 1 

Редактирование арифметической нейронной сети 

В топологии базовой (арифметической) НС присутствуют три типа узлов, 
В – входные узлы, ФН - формальные нейроны, П – нейроны смещения.  

Топология НС формируется перетаскиванием с помощью мышки узлов, 
расположенных на верхней панели, в рабочую область. Порядок размещения 
узлов следующий: слева находится первый слой узлов В нейронов, затем 
второй слой узлов, третий и т. д. (рис. 2).  

 
Рис. 2 
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Для удаления узла из топологии НС достаточно щелкнуть на нём правой 
кнопкой мыши. 

Редактирование нейро-нечеткой сети 

Процесс редактирования ННС аналогичен вышерассмотренному с той 
лишь разницей, что в качестве узлов скрытых слоев используются логические 
формальные нейроны, а именно: узлы И - ФН, реализующие логическую 
операцию конъюнкцию, узлы ИЛИ - нейроны, реализующие логическую 
операцию дизъюнкцию (рис. 3).  

 
Рис. 3 

Редактирование квазилогической нейронной сети 

Топология квазилогической НС повторяет топологию ННС (рис. 4).  

 
Рис. 4 

Отличие названных НС заключается в типе используемых ФН. В 
квазилогических НС в узлах скрытых слоев применяются арифметические ФН, 
реализующие функции  min  и max, подобные логической функции 
конъюнкции (узлы min)  и логической функции дизъюнкции (узлы max) [1 - 3].  
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Процесс формирования и редактирования квазилогической НС аналогичен 
вышерассмотренным. 

Открытие ранее созданного проекта 

Открытие ранее созданного проекта осуществляется с помощью опции 
меню Project->Open (рис. 5). В открывшемся окне Open neural network 
structure (рис. 6) отметьте файл с расширением nnf и, как и в любой другой 
программе, активируйте кнопку Open.  

 
Рис. 5 

 
Рис. 6 
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Закрытие проекта 

Для того чтобы закрыть проект в процессе работы программы (например, 
чтобы открыть другой), вам необходимо воспользоваться пунктом меню 
Project->Close (рис.7). 

 
Рис. 7 

Сохранение проекта  

Чтобы сохранить проект под определенным именем, вам нужно 
воспользоваться опцией меню Project->Save или Project->Save As (Рис. 8). 
Затем выбрать место на диске для сохранения, ввести имя файла и нажать 
кнопку Save (рис. 9). 

 
Рис. 8 

Упорядочение расположения нейронов 

Данная функция позволяет упорядочить размещение узлов в топологии НС 
по слоям сети, т. е. программа автоматически оптимизирует расстановку 
нейронов, расположенных в рабочей области окна. Для этого воспользуйтесь 
опцией Edit-> Align Neurons (рис.10) или нажмите клавишу F6.  
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Рис. 9 

 
Рис. 10 

Рис. 11 и 12 иллюстрируют вид рабочей области окна до и после 
применения функции Align Neurons. 

  
Рис. 11 
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Рис. 12 

Проверка на ошибки 

Выбрав опцию меню Edit-> Verify (или клавишу F7) задается режим 
проверки и автоматического исправления ошибок в типе узлов, размещенных в 
слоях НС (рис. 13).   

 
Рис. 13 

Ошибки, изображенные на рис. 13, например, входной узел В во втором 
слое НС, будут исправлены.  

Добавление в проект дополнительных сведений 

Для идентификации проекта можно добавить информацию о разработчике 
в поля имя и описание проекта окне Project Information (рис. 14), используя 
опцию меню Edit-> Edit information (рис. 15). 

 
Рис. 14 
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Рис. 15 

Именование входного и выходного слоя НС 

Вы можете переименовать входы и выходы нейронной сети, используя 
меню Edit-> Edit names (рис.16). В окне Names Editor (рис. 17) вы можете 
выбирать, какой слой редактировать:  

• First Layer – входной, 
• Last Layer – выходной. 

С помощью кнопок Move Up и Move down можно смещать имена вверх и 
вниз. С помощью нижнего поля можно редактировать текущее название. 

 
Рис. 16 
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Рис. 17 

 

1.2. Forecast 

Forecast – среда исследования процессов адаптации нейронных и нейро-
нечетких сетей позволяет выполнять следующие функции: 

• Загрузка модели 
• Ввод начальных данных 
• Выбор алгоритма обучения и обучение сети 
• График обучения сети 
• Предсказание  
• Экспорт результатов 
После активации программы открывается главное окно программы, 

предназначенное для организации пользовательского интерфейса в процессе 
формирования и обучения нейросетевых средств.  

При запуске программы открывается вкладка Model, предлагающая 
загрузить файл с топологией исследуемой НС (кнопка Load model).  

Загрузка модели 

Для загрузки модели нейронной сети, перейдите на вкладку Model и 
нажмите кнопку Load model (рис. 18). В открывшемся окне Loading data 
model выберите файл со структурой нейронной сети (с расширением nnf) и 
нажмите кнопку Load (рис. 19). 
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Рис. 18 

Ввод начальных данных 

Для обучения нейронной сети следует загрузить созданный заранее файл 
обучающей выборки в формате *.txt. Для этого необходимо нажать на кнопку 
import data на вкладке input главного окна программы, что приводит к 
открытию окна, в котором следует выбрать файл с импортируемыми данными.  

В таблице, расположенной на вкладке input, отражаются значения данных 
обучающей выборки, используемые для обучения загруженной НС (рис.20). 

 
Рис. 19 
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Рис. 20 

Также данные можно ввести из текстового файла, содержащего выборку 
данных. Для этого нажмите кнопку Import Data (рис. 21).  И в появившемся 
окне Import Data выберите необходимый текстовый файл (рис. 22). 

 
Рис. 21 

Выбор алгоритма обучения и обучение НС 

Для начала обучения сети перейдите на закладку Analysis (рис. 23), 
перейдите на закладку Algorithm (выбрана по умолчанию) и выберите один из 
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алгоритмов обучения: обратного распространения ошибки или генетических 
алгоритмов. Запустить процесс адаптации нажатием на кнопку Start.  

 
Рис. 22 

В методе обратного распространения ошибки (рис. 24) введите значение 
числа итераций (рекомендуемое значение – 4000) и задайте шаг приращения 
(рекомендуемое значение инкремента - 0.1). 

Рис. 23 



 16

 
Рис. 24 

В методе генетических алгоритмов (рис. 25) необходимо задать 
следующие параметры: количество итераций (рекомендуемое значение – 4000), 
вероятность мутации, вероятность перестановки. 

Рис. 25 
Отметьте символом √ «галочка» поле "Только связи к выходному слою", 

если хотите, чтобы обучались только связи выходного слоя НС, а не все 
межнейронные связи информационного поля НС. 

Для начала обучения нажмите кнопку Start (рис.26). 
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Рис. 26 

График динамики обучения НС 

После начала обучения вы автоматически перейдете на закладку Teaching 
(рис. 27), где в режиме реального времени будет отображаться график 
снижения ошибки в процессе обучения НС.  

 
Рис. 27 
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Качество адаптационных процессов в нейронной сети оценивается с 
помощью графических зависимостей, отражающих динамику ошибки обучения 
НС в зависимости от количества эпох обучения (в случае использования метода 
обратного распространения ошибки) или количества эволюционных циклов 
обучения НС при использовании метода генетических алгоритмов. 

Предсказание результата  

Для тестирования обученной НС перейти на вкладку Forecast (рис. 28) и 
удалить из полей выхода (окрашенных в синий цвет) имеющиеся значения. 
Затем нажать кнопку Forecast  для проверки правильности предсказания 
выходных значений по тестовым входным значениям (рис. 29). 

 
Рис. 28 

 
Рис. 29 
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Экспорт результатов 

Чтобы экспортировать результаты работы программы, необходимо перейти 
на закладку Export (рис.30) и выбрать один из трех предложенных вариантов: 

Рис. 
30 

1. Текстовый файл. Выберите пункт Plain Text и нажмите кнопку Export. В 
открывшемся окне Save Results (рис.31) выберите имя для сохраняемого 
файла и нажмите Save.  

 
Рис. 31 
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Рис. 32 
2. В виде HTML-странички. Выберите пункт HTML WebPage (рис. 32) и 

нажмите кнопку Export.  

 
Рис. 33 
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В открывшемся окне Save Results (рис. 33) выберите имя для сохраняемого 
файла и нажмите Save. 
3. В виде топологии нейронной сети (рис. 34 и 35). 

Рис. 34 

 
Рис. 35 
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2. Задания к лабораторным работам  

2.1. Задание к лабораторной работе № 2 

Исследовать основы организации и процессы обучения нейронных сетей с 
использованием возможностей интерактивной среды NeuralNetworkBuilder,  
Forecast и сформированных в предыдущей лабораторной работе баз знаний (на 
основе продукционных правил).  

1. Сформировать топологию нейронной сети в соответствии с заданием 
преподавателя.  

С этой целью выбрать опцию меню Project->Create (рис.1) и в 
открывшемся окне отметить один из трех типов нейронных сетей, которые 
поддерживает NeuralNetworkBuilder: 

 Basic Neural Network – арифметическая НС, 
 Fuzzy Neural Network - логическая (нейро-нечеткая) сеть, 
 Quazy Neural Network – квазилогическая НС. 

2. Отредактировать топологию нейронной сети.  
В топологии базовой (арифметической) нейронной сети могут 

присутствовать три типа узлов, В – входные узлы, ФН - формальные нейроны, 
П - полярные нейроны. Порядок размещения узлов следующий: слева 
находится первый слой узлов В нейронов, затем второй слой узлов, третий и т. 
д. (рис. 2).  

Топология НС редактируется перетаскиванием с помощью мышки узлов, 
расположенных на верхней панели, в рабочую область. Для удаления узла из 
топологии НС достаточно щелкнуть на нём правой кнопкой мыши. 

Процесс редактирования ННС аналогичен вышерассмотренному с той 
лишь разницей, что в качестве узлов скрытых слоев используются логические 
формальные нейроны, а именно: узлы И - ФН, реализующие логическую 
операцию конъюнкцию, узлы ИЛИ - нейроны, реализующие логическую 
операцию дизъюнкцию (рис. 3).  

Так как топология квазилогической НС (рис. 4) повторяет топологию ННС, 
то отличие заключается лишь в типе используемых ФН. В квазилогических НС 
в узлах скрытых слоев применяются арифметические ФН, реализующие 
функции  min  и max, подобные логической функции конъюнкции (узлы min)  
и логической функции дизъюнкции (узлы max).  

3. Используйте функцию автоматической расстановки нейронов в рабочей 
области окна программы. 
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Для упорядочения размещения узлов топологии НС по слоям сети 
используется функция автоматической оптимизации расстановки нейронов. 
Для этого следует выбрать опцию Edit-> Align Neurons (рис.10) или нажать 
клавишу F6.  

4. Выполнить автоматическую проверку топологии НС на ошибки, 
связанные с неверным размещением узлов по слоям нейронной сети. 

Выбрав опцию меню Edit-> Verify (или клавишу F7) задайте режим 
проверки и автоматического исправления ошибок в типе узлов, размещенных в 
слоях НС (рис. 13).  Допущенные ошибки будут исправлены.  

5. Сохраните проект под именем для дальнейших исследований нейронной 
сети. 

Чтобы сохранить проект под определенным именем, вам нужно 
воспользоваться опцией меню Project->Save или Project->Save As (Рис. 8). 
Затем выбрать место на диске для сохранения, ввести имя файла и нажать 
кнопку Save (рис. 9). 

6. Открыть ранее созданный проект нейронной сети. 
Открыть ранее созданный проект (лабораторная работа № 1) с помощью 

опции меню Project->Open (рис. 5). В открывшемся окне Open neural network 
structure (рис. 6) отметьте файл с расширением nnf и активируйте кнопку 
Open.  

Если необходимо, то откорректируйте топологию нейронной сети 
аналогично п. 2 настоящего задания. Сохраните проект под именем для 
дальнейших исследований нейронной сети. 

7. Идентифицируйте свой проект путем введения в него дополнительных 
сведений. 

Для идентификации проекта можно добавить информацию о разработчике 
в поля имя и описание проекта окне Project Information (рис. 14), используя 
опцию меню Edit-> Edit information (рис. 15). Сохраните проект под именем 
для дальнейших исследований нейронной сети. 

8. Задайте имена для координат входного и выходного векторов НС. 
С этой целью используйте опцию меню Edit-> Edit names (рис.16). В окне 

Names Editor (рис. 17) следует выбирать слой, подлежащий редактированию:  
• First Layer – входной, 
• Last Layer – выходной. 

С помощью кнопок Move Up и Move down можно смещать имена вверх и 
вниз. С помощью нижнего поля отредактируйте имена координат входного и 
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выходного векторов НС. Сохраните проект под именем для дальнейших 
исследований нейронной сети. 

9. Закройте проект. 
Для того чтобы закрыть проект воспользуйтесь опцией меню Project-

>Close (рис.30). 
Сформируйте заключение, выводы и Ваши рекомендации, связанные с 

проведенным исследованием.  
10. Представьте результаты выполнения исследований НС преподавателю. 
 

2.2. Задание к лабораторной работе № 3 

Для исследования процессов адаптации нейронных и нейро-нечетких сетей 
следует активизировать интерактивную среду Forecast. При запуске программы 
открывается вкладка model, предлагающая загрузить файл с топологией 
исследуемой НС (кнопка Load model).  

1. Загрузите топологию НС, подлежащей исследованию. 
Для загрузки модели нейронной сети, перейдите на вкладку model и 

нажмите кнопку Load model (рис. 18). В открывшемся окне Loading data 
model выберите файл со структурой нейронной сети (с расширением nnf) и 
нажмите кнопку Load (рис. 19). 

2. Введите данные обучающей выборки. 
Для обучения нейронной сети следует загрузить созданный заранее файл 

обучающей выборки в формате *.txt. Для этого необходимо нажать на кнопку 
import data на вкладке input главного окна программы, что приводит к 
открытию окна, в котором следует выбрать файл с импортируемыми данными. 
В таблице, расположенной на вкладке input, отражаются значения данных 
обучающей выборки, которые используются для обучения ранее загруженной 
нейронной сети. 

Также данные можно ввести из текстового файла, содержащего выборку 
данных. Для этого нажмите кнопку Import data (рис. 21).  И в появившемся 
окне Import data выберите необходимый текстовый файл (рис. 22). 

3. Осуществите выбор алгоритма обучения нейронной сети. 
Для начала обучения сети перейдите на вкладку Analysis (рис. 23), 

перейдите на закладку Algorithm (выбрана по умолчанию) и выберите один из 
двух алгоритмов обучения: метод обратного распространения ошибки и метод 
генетических алгоритмов. Запустить процесс адаптации нажатием на кнопку 
Start.  
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В методе обратного распространения ошибки (рис. 24) введите значение 
числа итераций (рекомендуемое значение – 4000) и задайте шаг приращения 
(рекомендуемое значение инкремента - 0.1). 

В методе генетических алгоритмов (рис. 25) необходимо задать 
следующие параметры: 

• количество итераций (рекомендуемое значение – 4000), 
• вероятность мутации, 
• вероятность перестановки. 

Отметьте символом √ «галочка» поле "Только связи к выходному слою", 
если хотите, чтобы обучались только связи выходного слоя НС, а не все 
межнейронные связи информационного поля НС. 

Для начала обучения нажмите кнопку Start (рис.26). 
4. Сформируйте графики динамики обучения нейронной сети для 

выбранных алгоритмов обучения НС. 
Следует выбрать закладку Teaching (рис. 27) для отображения режиме 

реального времени динамики снижения общей ошибки в процессе обучения 
НС.  

5. Проведите тестирование обученной нейронной сети. 
Для тестирования качества обучения нейронной сети необходимо 

проделать следующие действия. Перейти на вкладку Forecast (рис. 28), удалить 
из полей выхода (окрашенных в синий цвет) имеющиеся значения, нажать 
кнопку Forecast  для проверки правильности предсказания выходных значений 
по тестовым входным значениям (рис. 29). 

6. Сохраните результаты обучения нейронной сети. 
Чтобы экспортировать результаты работы программы, необходимо перейти 

на закладку Export (рис.30) и выбрать один из вариантов: 
 Текстовый файл. Выберите пункт Plain Text и нажмите кнопку Export. 
В открывшемся окне Save Results (рис.31) выберите имя для 
сохраняемого файла и нажмите Save.  

 HTML-страница. Выберите пункт HTML WebPage (рис.32) и нажмите 
кнопку Export.  

 Топология нейронной сети (рис. 34 и 35). 
В открывшемся окне Save Results (рис.33) выберите имя для сохраняемого 

файла и нажмите Save. 
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7. Действия по П. 3 – 6 выполнить для различных модификаций процесса 
обучения НС, как по методу обратного распространения ошибки, так и 
по методу генетических алгоритмов. 

Сформируйте заключение, выводы и Ваши рекомендации, связанные с 
проведенным исследованием.  

8. Представьте результаты выполнения исследований НС преподавателю. 
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