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Лабораторная работа «Построение 3D-моделей изде-
лий» 

Цель работы 

Цель практической работы состоит в том, чтобы на примере по-
строения 3D-модели сборки в CAD/CAM/CAE-системе CATIA:  

• Ознакомиться с базовыми инструментами и функциями модуля 
Assembly Design (Проектирование сборок); 

• Изучить методику построения 3D-моделей сборок по ранее разра-
ботанным моделям; 

• Научиться проектировать детали в контексте сборки. 
В результате выполнения лабораторной работы студенты изучат от-

дельные возможности модуля Assembly Design, необходимые для реше-
ния задач проектирования сборок. 

Практическая работа проводится с использованием CAD/CAM/CAE-
системы CATIA. 

Описание системы CATIA 

Система CATIA (Computer Aided Three-dimensional Interactive 
Application) – одна из самых известных и мощных CAD/CAM/CAE-
систем высокого уровня. Это комплексная система автоматизированного 
проектирования (CAD), технологической подготовки производства 
(CAM) и инженерного анализа (САЕ), включающая в себя передовой ин-
струментарий трёхмерного моделирования, подсистемы программной 
имитации сложных технологических процессов, развитые средства ана-
лиза и единую базу данных текстовой и графической информации. Сис-
тема позволяет эффективно решать все задачи технической подготовки 
производства – от внешнего (концептуального) проектирования до вы-
пуска чертежей, спецификаций, монтажных схем и управляющих про-
грамм для станков с ЧПУ и т.д. Кроме того, функциональность CATIA 
дополнительно включает в себя элементы, характерные для PDM-систем.  

Система CATIA имеет модульную структуру, в центре которой на-
ходится собственное математическое ядро – CNEXT. Такой подход по-
зволяет пользователю помимо макросов (которые поддерживают все сис-
темы класса hi-end), писать собственные модули для системы CATIA. 
Причем с выходом нового релиза самостоятельно написанный модуль не 
потребует внесения изменений. Данное решение позволяет развивать и 
наращивать функционал в значительно более короткие сроки, так как 
внедрение новых модулей не связано с изменением ядра программы. Яд-
ро CNEXT уравнивает в правах геометрические данные и технологиче-
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ские процессы. Это свойство системы тоже уникально. В дереве построе-
ний хранится не только история создания геометрии, но и процессы, и за-
траченные ресурсы.  

Система CATIA имеет несколько модулей: 
• Машиностроительное проектирование (Mechanical Design); 
• Разработка дизайна изделий (Shape Design and Styling); 
• Системный синтез промышленных изделий (Product Synthesis); 
• Проектирование производственных и коммуникационных систем 

(Equipment and Systems Engineering); 
• Инженерный анализ (Analysis); 
• Программирование обработки на станках с ЧПУ (NC Manufactur-

ing); 
• Управление проектированием и обмен данными (Infrastructure); 
• Разработка приложений к CATIA (RADE Products); 
В лабораторной работе будет изучен модуль Assembly Design (Про-

ектирование сборок), входящий в группу модулей Mechanical Design 
(Машиностроительное проектирование). Данный модуль позволяет легко 
определить механические ограничения узлов, автоматически позициони-
рует и ограничивает движение компонентов, проверяет операции сборки 
на непротиворечивость. 

Модуль помогает проектировщикам определять большие иерархиче-
ские сборки и работать с ними, используя подход как "сверху-вниз", так и 
"снизу-вверх". Компоненты сборки можно легко устанавливать на место с 
помощью мыши или специальных инструментов. Сборочные ограниче-
ния позволяют контролировать положение деталей в сборке и устанавли-
вать контакты между ними. Позиционировать компонент в пространстве 
относительно других компонентов можно несколькими способами: бук-
сировкой курсором мыши, трансформацией типа переноса и вращения и 
совмещением по граням и кромкам. Одновременно к компоненту могут 
быть приложены механические связи с другими компонентами (соос-
ность, компланарность, эквидистанта, угловая константа и др.). Они яв-
ляются полноправными элементами описания изделия и входят в его спе-
цификацию. 

Детали можно повторно использовать в этой или в другой сборке, 
при этом не происходит дублирование данных. Модуль Проектирования 
сборок Assembly Design обеспечивает легкость создания и управления 
структурой сборки двумя путями. Компонент может быть вставлен в оп-
ределенное место в структуре сборки и наделен механическими связями с 
другими компонентами либо создан «по месту», опираясь на окружаю-
щую его конструктивную обстановку. Структура сборки может иметь не-
ограниченное количество уровней. 
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В CATIA обеспечено параллельное проектирование несколькими 
пользователями благодаря тому, что каждый компонент сборки имеет 
свою собственную спецификацию, но может быть применен в различных 
местах сборки несколько раз, без дублирования данных. Когда модули 
трехмерного проектирования и сборки используются вместе, любой эле-
мент, вовлеченный в сборку, может быть изменен как индивидуально, так 
и в контексте сборки. 

Компоненты сборки можно модифицировать (изменять геометриче-
ские параметры), «растаскивать» в пространстве произвольным образом, 
при этом не разрушая присвоенные им механические связи, а затем авто-
матически приводить всю конструкцию в собранное состояние. 

Двунаправленные ассоциативные взаимосвязи между деталями, 
сборками и их чертежами CATIA гарантируют соответствие модели и 
чертежа, так как все изменения сделанные в детали автоматически пере-
даются связанную с ней сборку и чертеж. 

Создаваемый при работе с CATIA пользователем проект имеет фай-
ловую структуру. При этом для различных видов информации использу-
ются различные расширения файлов. Например, для деталей – *.CATPart, 
для сборочных единиц – *.CATProduct, для чертежей – *.CATDrawing и 
т.д. 

Важным элементом представления информации проекта является де-
рево проекта. Оно содержит состав всех компонентов проекта в структу-
рированном виде. Элементами дерева проекта являются: 

• Механические сборочные единицы и детали, геометрические ком-
поненты деталей; 

• Объекты специальной предметной области (электрожгуты, кабели, 
трубопроводы, конструкции и т.д.); 

• Чертежи, листы и виды чертежей; 
• Технологические процессы обработки на станках с ЧПУ (последо-

вательность процедур и используемый инструмент); 
• Механические связи между элементами сборки (соосность, совме-

щение плоскостей, фиксация расстояний и др.);  
• Представление знаний – параметры, формулы, правила и базы пра-

вил; 
• Дополнительные средства описания проекта – 3D-аннотации, за-

кладки, множества, сцены, гиперссылки, слайды, фильмы и др. 
Таким образом, задачи по проектированию сложных изделий и сис-

тем в CATIA решаются в трехмерном пространстве, на уровне виртуаль-
ных моделей. CATIA устраняет необходимость физического макетирова-
ния деталей и узлов для анализа их форм, компоновки, прочностных ха-
рактеристик и т.д. Это экономит предприятию материальные ресурсы, со-
кращает время проектирования и подготовки производства изделий. В 
конечном счете, виртуальное макетирование в CATIA V5 снижает стои-
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мость продукции предприятия и сокращает время выхода этой продукции 
на рынок. 

Постановка задачи 

Практическая работа состоит из трех частей. 
Задача первой части – создать сборку по ранее разработанным 3D-

моделям деталей. Проектируемая сборка должна удовлетворять ряду тре-
бований: 

1) Первый компонент должен быть фиксирован. Несмотря на то, что 
фиксирование первого компонента в CATIA не обязательно, на 
практике это может оказаться полезным. 

2) Все компоненты должны быть полностью ограничены. Полное ог-
раничение компонентов позволяет исключить возникновение неже-
лательных изменений. 

3) Необходимо использовать инструменты дублирования. Повторное 
использование существующих компонентов значительно сокращает 
время разработки. 
Во второй части практической работы необходимо спроектировать 

деталь в контексте сборки. Создаваемая деталь должна удовлетворять ря-
ду требований:  

1) Модель должна быть создана внутри сборки. 
2) Эскиз базового примитива детали должен базироваться на плоской 

грани смежного компонента. 
В третьей части необходимо провести анализ сборки. Анализ сборки 

должен содержать: 
1) Анализ ограничений сборки. 
2) Определение числа степеней свободы компонентов сборки. 
3) Анализ ограничений компонентов при помощи инструмента разне-

сения сборки. 

Руководство к проведению лабораторной работы 

Данная лабораторная работа проводится с использованием 
CAD/CAM/CAE системы CATIA. Поэтому для выполнения работы необ-
ходима предварительная установка данного программного обеспечения. 
Реализация работы осуществляется на базе компьютерного класса кафед-
ры ТПС. 

Исходные данные для выполнения лабораторной работы: 
• сборочный чертеж и спецификация (Приложение 1); 
• 3D-модели деталей; 
• чертеж детали, проектируемой в контексте сборки (Прило-

жение 2). 
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Файлы с моделями деталей находятся в папке “3D-модели сборок”, 
номер папки соответствует номеру варианта. 

Внимание! Названия файлов создаваемых в системе CATIA 
должны вводиться латинскими буквами. 

В сборке могут использоваться как заранее построенные компонен-
ты, так и компоненты, созданные внутри сборки. Сборка, содержит дере-
во спецификации, в котором отображаются вставленные компоненты и 
ограничения, используемые для позиционирования компонентов. 

1 часть. Создание сборки по существующим моделям 

В процессе создания 3D-модели сборки выполняется несколько эта-
пов. 

1. Создать новый документ CATProduct. 
2. Добавить базовый компонент. 
3. Управлять положением компонента и зафиксировать его. 
4. Добавить компоненты сборки. 
5. Установить ограничения компонентов сборки.  
6. Скрыть все ограничения и видимые вспомогательные плоскости. 

Этап 1. Создать новый документ CATProduct 
Сборки создаются в рабочей среде Assembly Design (Проектирование 

сборок). Файл сборки имеет расширение .CATProduct. Существует три 
способа создания нового документа CATProduct: 

• Через меню Start > Mechanical Design > Assembly Design;  
• Выбрать File>New>Product; 

• Используя иконку New  на панели инструментов Standart. 
После создания нового документа, при помощи правой клавиши 

мыши и меню Properties (Свойства), необходимо задать описательную 
информацию об изделии. В поле Part Number (обозначение сборки) вве-
сти обозначение сборки. 
Этап 2. Добавить базовый компонент 

Первый элемент, добавленный в сборку должен быть самым ста-
бильным! 

Добавить существующий компонент можно: 
• Через контекстное меню сборки Components/Existing Component 

(Существующий компонент)… 

• При помощи иконки Existing Component  
• При помощи меню Insert >Existing Component (Вставка >Сущест-

вующий компонент). 
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Этап 3. Управлять положением компонента и зафиксировать его 
В CATIA существует несколько способов просмотра модели. Самы-

ми простыми способами изменения вида модели являются перемещение, 
вращение, масштабирование. 

• Перемещение в плоскости экрана осуществляется при нажатии и 
удерживании средней кнопки мыши. 

• Вращение позволяет поворачивать модель вокруг точки. Для этого 
необходимо нажать и удерживать среднюю кнопку мыши, одно-
временно щелкнув и удерживая левую кнопку мыши. 

• Масштабирование позволяет увеличивать или уменьшать размер 
модели в плоскости, параллельной плоскости экрана. Для этого не-
обходимо нажав и удерживая среднюю кнопку мыши перемещать 
курсор вверх или вниз, а затем один раз щелкнуть левой кнопкой 
мыши. 

В CATIA для управления вставленными в сборку компонентами ис-
пользуется инструмент Компас (по умолчанию, компас расположен в 
правом верхнем углу экрана). Компас является вспомогательным инстру-
ментов ориентации при вращении вида, а также используется для физиче-
ского перемещения объектов в пространстве и манипулирования ими. 
Компас позволяет перемещать и вращать сборку целиком, а также сво-
бодно передвигать и поворачивать ее компоненты. 

• Если компонент ограничен, то это вращение временное, поскольку 
не сохраняется в документе детали CATPart, ни в документе сборки 
CATProduct. Изменяется только направление взгляда.  

• Если этот компонент не имеет ограничений, его новое положение 
сохраняется в документе CATProduct.  

Для того чтобы переместить компонент с помощью компаса, необхо-
димо выполнить следующие шаги: 

1. Поместить компас на компонент. 
Навести курсор на красный квадрат в основании компаса, при этом 

значок курсора должен измениться. Нажать и удерживать левую кнопку 
мыши, чтобы передвинуть компас. В движении компас меняет свою фор-
му. Когда компонент выбран, компас принимает положение, совпадаю-
щее с геометрическим элементом, находящимся под ним. Чтобы выбрать 
компонент, нужно отпустить левую кнопку мыши. 

2. Выбрать вид движения, перемещая курсор по компасу. Подсвечи-
ваемые элементы компаса показывают доступное движение. 

3. С помощью левой кнопки мыши переместить компонент. 
После добавления базового компонента, он может быть оставлен 

“плавающим” в пространстве (без ограничений), но желательно зафикси-
ровать этот компонент. В зафиксированном положении он в дальнейшем 
будет служить основным элементом для размещения остальных компо-
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нентов сборки. Компоненты, зафиксированные в пространстве, возвра-
щаются в свое исходное положение при обновлении ограничений (т.е. 
восстанавливаются). 

Фиксирование компонента в пространстве:  

1. Выбрать иконку Fix (Фиксировать)  на панели инструментов 
Constraints. 

2. Выбрать компонент, который необходимо зафиксировать, в дереве 
спецификации или в геометрической области. 

После того, как компонент был зафиксирован, положение его в сбор-
ке можно на время изменить. Но после обновления сборки, ограничения 
будут пересчитаны, и компонент вернется в заданное положение. 
4 этап. Добавить компоненты сборки 

В сборку существующий компонент может быть добавлен одним из 
трех способов рассмотренных на втором этапе. 

В сборке может присутствовать более одного экземпляра компонен-
та. Возможности Copy (Копировать) и Paste (Вставить) позволяют легко 
дублировать компонент. Для этого необходимо выполнить шаги. 

1. Щелкнуть правой кнопкой мыши по компоненту.  
2. Выбрать в контекстном меню команду Copy (Копировать).  
3. Щелкнуть правой кнопкой мыши сборку, в которую нужно вста-

вить компонент.  
4. Выбрать в контекстном меню команду Paste (Вставить).  
При копировании и вставке компонента можно контролировать, бу-

дут или нет, одновременно с компонентом копироваться его ограничения. 
Для того чтобы компонент копировался без ограничений необходимо: 

1. Выбрать Tools > Options (Инструменты > Опции), чтобы открыть 
окно Options.  

2. Выделить ветвь Assembly Design в узле Mechanical Design.  
3. Открыть вкладку Constraints (Ограничения).  

4. Выбрать опцию  в секции 
Paste Components (Вставка компонентов).  

Эти опции начинают применяться в сеансе работы и не требуют пе-
резапуска CATIA. 
5 этап. Установить ограничения компонентов сборки 

Когда компоненты добавляются в сборку, они могут перемещаться и 
вращаться в любом направлении. При наложении ограничений на компо-
нент уменьшается число степеней его свободы. В идеальном случае, чис-
ло степеней свободы каждого компонента сборки должно равняться ну-
лю. Это исключает возникновение нежелательных перемещений между 
компонентами и обеспечивает полное соответствие сборки требованиям 
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технического задания в процессе ее модификаций. Ограничения сборки 
используются для определения взаимного расположения существующих 
компонентов. 

Вставленные в продукт компоненты должны быть расположены с 
учетом остальных компонентов. До определения ограничений, компонен-
ты можно установить в нужное положение с помощью компаса. Пока на 
компонент не наложено никаких ограничений, он может свободно пере-
мещаться в пространстве. Используя эту возможность, компонент следует 
перенести в положение, близкое к требуемому, и только затем точно за-
фиксировать его с помощью ограничений. 

Задавать ограничения в сборке следует в следующей последователь-
ности: 
1. Зафиксировать в пространстве положение одного из компонентов. Это 
будет начальный компонент. 
2. Переместить компонент с помощью компаса близко к нужному поло-
жению. В дальнейшем это позволит проще накладывать ограничения. 
3. Точно позиционировать компонент, выбрав и применив подходящее 
ограничение(я). 
4. Проверить полученный результат, обновив сборку. Компоненты займут 
свое положение в соответствии с наложенными ограничениями. 

Относительное положение компонента устанавливается с помощью 
ограничений. Для задания ограничений может быть использован один из 
следующих методов:  

• С помощью панели инструментов Constraints (Ограничения); 
• С помощью меню Insert (Вставка).  
Ниже приведена таблица, содержащая символы, которыми обозна-

чаются ограничения между компонентами.  
Ограничение Coincidence (Совпадение) обеспечивает соосность, 

компланарность или совпадение точек. Для создания Coincidence необхо-
димо выполнить последовательность шагов. 
Если для выравнивания нужно сделать плоскости компланарными, 
CATIA позволяет выбрать ориентацию с помощью двух зеленых стрелок. 
Чтобы определить ориентацию, необходимо выполнить шаги. Нажать на 
одну из зеленых стрелок, чтобы изменить ориентацию перемещаемого 
компонента. 

Ограничение Contact (Контакт) соединяет две плоскости или гра-
ни. Для задания этого ограничения необходимо выполнить шаги. 

Ограничение Offset (Смещение) определяет расстояние между дву-
мя элементами. 
Чтобы применить это ограничение, необходимо ввести значение смеще-
ния. 
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Выбрать ориентацию (водном или противоположном направлении), 
щелкнув на зеленую стрелку или выбрав соответствующую опцию в вы-
падающем меню Orientation. 

Таблица .1Ограничения и их обозначения 

Ограничения 
Обозначение  

в геометрической об-
ласти 

Обозначение 
в дереве специ-

фикации 

Coincidence (Совпа-
дение)  

  

Contact (Контакт)  
  

Offset (Смещение)  
 

 
Angle (Угол) Planar 
Angle (Плоский угол)   
Parallelism (Парал-
лельность)   
Perpendicularity (Пер-
пендикулярность)  

  

Fix (Фиксировать)  
  

Fix together (Фикси-
ровать вместе)  

 

Ограничение угла Angle (Угол) определяет угол между элементами 
компонентов 
С помощью ограничения Angle (Угол) также можно задать параллель-
ность или перпендикулярность двух элементов. Если определяется па-
раллельность, можно выбрать ориентацию компонентов в одном или про-
тивоположном направлении. Чтобы применить это ограничение, необхо-
димо выполнить последовательность шагов. 
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1. Выбрать иконку Angle.  
2. Выделить две плоскости, которых уточняется ограничение. 
3.Выбрать опцию Parallelism (Параллельность) или опцию 
Perpendicularity (Перпендикулярность).  
4. Если выбрана опция Parallelism, определить ориентацию.  
Ограничение Fix together (Фиксировать вместе) позволяет приме-

нять к компонентам такие ограничения, при которых они двигаются как 
единый объект. Можно выбирать больше двух компонентов. Вокне Fix 
Together отображается список всех выбранных компонентов.  

В CATIA установлены следующие правила работы с ограниче-
ниями:  

• Ограничения могут применяться только между дочерними компо-
нентами активного компонента; 

• Нельзя задавать ограничения между геометрическими элементами, 
принадлежащими одному компоненту;  

• Нельзя применять ограничение между компонентами одной под-
сборки, если подсборка не является активным элементом дерева 
спецификации.  

При нарушении установленных правил, в процессе создания ограни-
чений могут возникать ошибки, сообщения о которых появляются в окне 
Assistant (Помощник).  

Обновление ограничений 
При обновлении сборки CATIA повторно пересчитывает все нало-

женные на компоненты ограничения. Ограничения, требующие обновле-
ния, обозначаются в дереве спецификации и на модели. Обновлять можно 
сразу все ограничения или каждое отдельно, используя один из способов, 
описанных ниже.  

• Для обновления всех ограничений и деталей в сборке использовать 

иконку Update  на панели инструментов Tools.  
• Для обновления одного ограничения необходимо щелкнуть правой 

кнопкой мыши по этому ограничению в дереве спецификации или в 
геометрической области, затем в контекстном меню выбрать ко-
манду Update. 

6 этап. Скрыть все ограничения и видимые вспомогательные плоскости 
Для упрощения отображения модели необходимо скрыть все ограни-

чения и видимые вспомогательные плоскости. Скрыть элементы можно 
двумя способами: 

• Щелкнуть на элемент, который необходимо скрыть, правой кноп-
кой мыши и выбрать Hide/Show (Скрыть/Показать) из контекстного 
меню. 

• При помощи меню Tools > Hide (Инструменты > Скрыть). 
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2 часть. Создание детали в контексте сборки 

Исходными данными для выполнения второй части лабораторной 
работы являются сборочный чертеж (Приложение 1) и чертеж детали 
(Приложение 2), которую необходимо создать в контексте сборки. Деталь 
проектируется в контексте сборке, созданной в первой части работы. 

Для определения новой детали необходимо использовать уже су-
ществующие компоненты. 

Процесс проектирования детали в сборке состоит из следующих эта-
пов: 

1. Добавить новую деталь в сборку.  
2. Создать эскиз детали.  
3. Создать деталь. 
Основанием эскиза должна быть плоская грань смежного компонен-

та. Ограничения в эскизе должны быть определены с помощью элементов 
других компонентов.  
1 Этап. Добавить новую деталь в сборку 

Добавить новую деталь можно: 
• Через контекстное меню сборки Components/ New Part (Новая де-

таль). 

• При помощи иконки New Part  
• При помощи меню Insert > New Part (Вставка > Новая деталь). 
В контекстном меню Properties (Свойства) необходимо задать обо-

значение детали. 
2 Этап. Создать эскиз детали 

Для построения примитивов детали внутри сборки необходимо: 
1. Перейти в режим редактирования детали Part Design (при помощи 
двойного щелчка мыши). 
2. Выбрать плоскую поверхность смежного компонента и перейти в 

режим Sketcher (Эскиз) . 
3. В режиме создания эскиза, нарисовать эскиз для создания детали. 
Для того чтобы деталь удовлетворяла указанным требованиям необ-

ходимо наложить ограничения при помощи инструмента  Constraints 

Defined (Определение ограничения) . 
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3 Этап. Создать деталь 
Для создания детали необходимо воспользоваться командами Pad 

(Призма)  или Pocket (Карман) . 

3 часть. Анализ ограничений сборки 

В третьей части лабораторной работы необходимо проанализировать 
состояние всех связей сборки. Анализ состоит из трех этапов: 
1 Этап. Анализ ограничений 

Для выполнения анализа ограничений сборки необходимо встать на 
сборку и выбрать Analyze > Constraints (Анализ > Ограничения). Появит-
ся диалоговое окно Constraint Analysis (Анализ ограничений) со всей не-
обходимой информацией. Закладка Constraints (Ограничения) отображает 
детальное состояние ограничений в сборке: число не ограниченных ком-
понентов (not constrained) и состояния определённых ограничений.  

Если ограничения заданы правильно, то число нарушенных связей 
будет равно нулю. 

Если имеются нарушенные связи, необходимо выяснить причину и 
избавиться от них (нарушенная связь обозначена желтым предупреди-
тельным символом). 
2 Этап. Анализ числа степеней свободы компонентов сборки 

Устанавливая ограничения, сокращается число степеней свободы 
компонента. Компонент сборки должен быть полностью ограничен, то 
есть число степеней свободы должно равняться нулю. Для выполнения 
проверки степеней свободы компонента необходимо выделить этот ком-
понент правой кнопки мыши и выбрать в контекстном меню x.object > 
Components Degrees of Freedom (Объект > Степень свободы компонента). 
Все оставшиеся степени свободы отображаются в окне Degrees of 
Freedom Analysis (Анализ степеней свободы). 
3 Этап. Проверка  наложения ограничений сборки 

Среда "Разнесенная сборка", как и следует из названия, предназначе-
на для создания разнесенных видов, иллюстрирующих порядок сборки, 
состав изделия или взаимосвязи между отдельными частями механизма. 
Средства автоматического построения вида смещают детали и узлы в со-
ответствии с порядком сборки и со связями, наложенными на элементы 
сборки. При изменении сборки автоматически меняется и разнесенный 
вид. Все построенные разнесенные виды сборки могут быть легко пока-
заны на чертежах, что особенно важно для создания технических руко-
водств. 
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Для создания разнесённой сборки необходимо выполнить следую-
щие действия: 

1. Выделить сборку. 

2. Нажать иконку Explode (Разнести)  на панели инструментов 
Move (Движение). Появится диалоговое окно Explode. 

Параметр Depth (Глубина) позволяет Вам выбирать между полным 
(All levels) и частичным (First level) разнесенным видом. 

3. Выберите All levels.  
4. Выберите 3 D для определения типа разнесения.  
5. Нажмите Apply для завершения операции. Поле Scroll Explode 

отображает процесс выполнения операции. 
Данный анализ позволяет просмотреть всех компоненты сборки от-

дельно. 

Содержание отчета 

Отчёт по лабораторной работе должен содержать: 
1. Цель лабораторной работы. 
2. Постановку задачи. 
3. Исходные данные. 
4. 3D-модель сборки. 
5. Анализ сборки. 
6. Выводы по проделанной работе. 
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Лабораторная работа «Анализ геометрических пара-
метров 3D-моделей» 

Цель работы 

Цель практической работы состоит в том, чтобы на примере выпол-
нения измерений на трехмерной модели изделия в CAD/CAM/CAE сис-
теме CATIA: 

• познакомиться с возможностями современных CAD-систем по ана-
лизу геометрии 3D-моделей изделия; 

• освоить методы выполнения измерений в виртуальном 3D-
пространстве системы; 

• изучить механизм создания геометрии в результате проведенных 
измерений; 

• получить дополнительные навыки работы CAD/CAM/CAE системе 
CATIA. 
Практическая работа проводится с использованием CAD/CAM/CAE-

системы CATIA. 

Реализация инструментов измерения в CATIA 

Дополнительный функционал CAD-систем в виде встроенного меха-
низма измерения трехмерных моделей изделия позволяет получать раз-
мерное описание: 

• геометрических элементов 3D-модели изделия, для которых разме-
ры не указаны в явном виде; 

• 3D-моделей, импортированных из других CAD-систем; 
• отдельных геометрических элементов и всей модели в целом в слу-

чае скрытой истории построения (дерева построения). 
В CATIA существуют три типа измерения: 

• Инструмент Measure Between (измерение расстояний между эле-
ментами модели). 

• Инструмент Measure Item (измерение отдельных элементов моде-
ли). 

• Инструмент Measure Inertia (измерение инерционно-массовых ха-
рактеристик). 
Для первого типа (Measure Between) в CATIA используются три ре-

жима простановки размеров: стандартный (каждый размер создается не-
зависимо (рис. 1, А)), «от общей базы» (измерение выполняется между 
первым выбранным элементом и каждым следующим (рис. 1, В)), «це-
почкой» (второй выбранный для измерения элемент автоматически ста-
новится первым элементом для следующего измерения (рис. 1, С)). 
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Рис. 1. Инструмент Measure Between 

Второй тип измерений используется для измерения отдельных гео-
метрических элементов. С помощью этой функции можно рассчитать та-
кие величины как площадь,  периметр, радиус и др. 

В результате третьего типа измерений можно получить значения 
объема, массы, координаты центра масс и другие характеристики элемен-
тов. При этом анализируются 2D и 3D поверхности. 

Следует отметить, что все инструменты измерения имеют возмож-
ность создавать новую геометрию. Для иллюстрации измерений могут 
генерироваться точки, линии и координатные системы. По умолчанию, 
полученная в результате измерений геометрия ассоциативна. Если про-
изойдут изменения в исходных измеряемых элементах, то соответственно 
связанная с измерениями геометрия перестроится. Однако можно изме-
нить умолчания и геометрия, полученная таким образом, будет не ассо-
циативной, тогда после редактирования исходной модели она останется 
неизменной.  

Постановка задачи 

Выполнение практической работы осуществляется в модуле Part De-
sign системы CATIA V5. 

Для решения поставленной задачи необходимо использовать утили-
ты: 

• Measure Between. 
• Measure Item. 
• Measure Inertia. 

 19



• Creation of Geometry. 
• Part Infrastructure (Automatic Update). 
• Parameter and Measure (Measure Tools). 
Необходимо выполнить ряд действий по измерению 3D-моделей в 

CATIA V5: 
• Выполнить настройку компонентов измерения (Components). 
• Провести указанные в задании к лабораторной работе измерения и 

зафиксировать их в дереве проекта в CATIA V5. 
• На основании проведенных расчетов провести построение допол-

нительной геометрии. 

Руководство по проведению лабораторной работы 

Данная лабораторная работа проводится с использованием 
CAD/CAM/CAE системы CATIA. Поэтому для выполнения лабораторно-
го практикума необходима предварительная установка данного про-
граммного обеспечения. Реализация работы осуществляется на базе ком-
пьютерного класса кафедры ТПС. 

Исходные данные для выполнения лабораторной работы:  
• чертежи деталей и таблицы исходных данных (Приложение 3); 
• 3D-модели деталей. 
Файлы с моделями деталей находятся в папке “Варианты заданий”, 

номер папки соответствует номеру варианта. 
Рассмотрим выполнение данного лабораторного практикума на при-

мере измерения Угольника  000.000.011 (рис. 2). 

 
Рис. 2. Угольник 000.000.011 
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В задании требуется: 
1. Измерить расстояние между элементами – построить размеры:  

• a и b от общей базы; 
• c, d и e  в виде цепочки размеров. 

2. Измерить элементы – получить значение: 
• площади плоскости f; 
• площади поверхности g.  

3. Получить следующие характеристики  детали: 
• координаты центра масс цилиндра ∅4; 
• координаты центра масс детали; 
• массу детали; 
• площадь поверхности детали. 

4. Построить пользовательскую систему координат в центре масс 
цилиндра ∅4. 

Перед началом работы необходимо открыть в CATIA V5 3D-модель 
детали (модуль Part Design).  

Выбор элементов измерения, менеджер измерений 

Для проведения измерений в CATIA V5 необходимо запустить ме-
неджер измерений соответствующего типа. Для этого необходимо вос-
пользоваться панелью инструментов Measure (рис. 1). 

После чего требуется указать измеряемые объекты. В процессе вы-
бора значок курсора показывает тип выделенного элемента. Распознаются 
следующие типы элементов (рис. 3): 

• цилиндрическая поверхность; 
• плоскость или плоская поверхность; 
• центр окружности; 
• линия; 
• точка. 
Это позволяет быть уверенным в том, что выбирается требуемый для 

измерения элемент. 
Еще одним способом убедиться в правильности выбора элемента яв-

ляется конкретное указание типа выбираемого элемента. Это обеспечива-
ется с помощью выпадающего меню (Selection mode) в окне режима ме-
неджера измерений (рис. 4). 

Менеджер измерений позволяет изменять тип и режим измерения, 
накладывать ограничения на вид выбираемых элементов (меню Selection 
mode или панель настроек Customize) и результат измерений (панель на-
строек Customize), создавать дополнительную геометрию (панель Create 
Geometry). Настройка Keep Measure регулирует процесс сохранения из-
мерений в дереве проекта. 
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Рис. 3. Интерактивное изменение вида курсора в зависимости от типа 
объекта 

Измерение расстояний между элементами 

Как указывалось выше, существуют три режима данного типа изме-
рений. Для выполнения первого пункта задания необходимо воспользо-
ваться опциями «построение размеров от общей базы» (например, a и b) и 
«цепочкой» (например, c, d и e), рис. 4. Для того чтобы все размеры нахо-
дились в одной плоскости, необходимо указывать в качестве элементов 
измерения ребра детали (расположенные в одной плоскости), а не целые 
поверхности. 

Сложность вызовет построение размера e. Это связано с тем, то один 
из элементов измерения представляет собой цилиндрическую поверх-
ность. Для построения размера в этом случае необходимо предварительно 
создать вспомогательную плоскость, параллельную основанию угольника 
и касающуюся цилиндрической поверхности (R6,5). Данную плоскость 
необходимо указать как последний элемент для измерения. 
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Рис. 4. Менеджер измерений и состав параметров меню Customize для 
режима Measure Between 

По умолчанию, в отчете результатов измерений, публикуется крат-
чайшее расстояние между двумя элементами. Есть механизм регулирова-
ния результатов измерения. Например, для получения компонентов рас-
стояния (то есть, расстояний в направлениях X, Y и Z) относительно ко-
ординатной системы необходимо нажать Customize и выбрать опцию 
Components (компоненты расстояния). Компоненты расстояния отобра-
жаются в окне Results (результаты). 

Измерение объекта 

Функция Измерение объекта (Measure Item) позволяет измерять от-
дельные геометрические элементы. Для измерения объекта необходимо 
выполнить последовательность шагов. 

• Нажать иконку Measure Item (Измерение объекта). 
• Выбрать геометрический элемент, который необходимо измерить. 
• Характеристики выбранного геометрического элемента отобража-

ются на модели и 
• в окне результатов. 
• Для сохранения измерения необходимо выбрать опцию Keep 

Measure. 
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• Для завершения измерения нажать OK. 
• Если была выбрана опция Keep Measure, измерение остается в мо-

дели и добавляется в дерево спецификации. 
Таким образом, для построения размеров f и g достаточно указать 

соответствующие элементы на 3D-модели. 
Меню Customize позволяет скорректировать выбор элементов. Для 

данного типа измерений Customize включает следующие разделы: точки, 
ребра, элементы окружности, поверхности, 3D-свойства. Назначая те или 
иные атрибуты в меню можно создать условия измерения. 

Инерционно-массовые характеристики 

Для вычисления инерционно-массовых характеристик 3D-объектов с 
помощью функции Measure Inertia (измерение инерции) необходимо вы-
полнить следующее: 

• Нажать иконку Measure Inertia. 
• Выбрать PartBody в дереве спецификации. 
• Посмотреть результаты в менеджере измерений. 
На модели при этом будет отображаться центр  масс изделия. 
Для редактирования состава результатов необходимо воспользовать-

ся Customize. Для данного типа измерений Customize отображает все виды 
результатов, которые возможно получить при измерении (площадь, мас-
су, координаты центра масс, момент инерции и другие характеристики). 

Measure Inertia включает два режима работы: измерения в 2D и в 3D. 
Состав характеристик измерения при этом различается (рис. 5). 

Построение дополнительной геометрии 

Для построения любых дополнительных геометрических элементов с 
помощью инструмента Measure необходимо воспользоваться инструмен-
том Creation Geometry. Данным инструментом можно воспользоваться, 
указав соответствующую кнопку в менеджере Measur (рис. 4). В зависи-
мости от типа измерения системой для построения будет предложен раз-
личный состав дополнительных элементов. Например, при указании от-
резка такими элементами будут точки на концах и в середине отрезка, а 
при выборе цилиндрического отверстия это могут быть как точка в цен-
тре масс цилиндра (Measure Item), так и дополнительная система коорди-
нат в центре масс цилиндра (Measure Inertia). 

То есть в соответствии с заданием для получения значений коорди-
нат центра масс необходимо произвести построение этого элемента 
(Creation Geometry), а потом в его характеристиках уточнить конкретное 
значение координат по осям. 
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Рис. 5. Состав параметров меню Customize для режима Measure Inertia 
(а – для двухмерных элементов измерения, b – для трехмерных) 

Содержание отчета 

Отчёт по лабораторной работе должен содержать: 
1. Цель лабораторной работы. 
2. Постановку задачи. 
3. Исходные данные. 
4. Параметры дерева построения Measur. 
5. 3D-модели CATIA V5 с результатом работы. 
6. Выводы по проделанной работе. 
Замечание: для проведения некоторых измерений требуется выпол-
нить дополнительные построения. 

 25



 Лабораторная работа «Статический расчёт круглой 
пластины с применением метода конечных элемен-
тов» 

Цель работы 

Цель данной практической работы состоит в том, чтобы на примере 
статического расчета круглой пластины ознакомиться: 

• с конечными элементами поверхностей; 
• с методикой моделирования поведения конструкции с применением 

элементов поверхностей; 
• со способами представления результатов моделирования. 
В результате выполнения лабораторной работы студенты должны 

приобрести навыки по компьютерному моделированию в инструменталь-
ной среде Nastran/Patran, которые они смогут применить на практике. 

Элементы поверхностей 

Элементы поверхностей имеют два измерения и используются для 
представления конструкций, имеющих малую толщину по сравнению с 
другими размерами (см. рис. 6, на котором указаны соотношения между 
размерами). Элементы поверхностей моделируют плоские пластины или 
оболочки (shell), которые имеют существенную кривизну (подобно ци-
линдру) или двойную (подобно сфере). Для узлов, соединяющих пласти-
ны, жесткости будут существовать для пяти из шести возможных степе-
ней свободы. Вращательная степень свободы относительно нормали к 
пластине «не связана». Эта степень должна быть закреплена, чтобы пре-
дотвратить сингулярность матрицы жесткости. 

Для линейных задач в MSC.Nastran для элементов поверхностей 
приняты следующие допущения: 

• тонкая пластина имеет толщину во много раз меньшую, чем другие 
размеры пластины; 

• прогиб пластины в середине мал по сравнению с ее толщиной; 
• срединный (нейтральный) слой остается ненапряженным при изги-

бе, это относится к горизонтальным нагрузкам, но не к нагрузкам 
вне срединной плоскости; 

• нормаль к срединному слою остается нормальной при изгибе пла-
стины. 
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Рис. 6. Три модели, применяемые для описания свойств мембраны 

Quadrilateral Plate Element (CQUAD4) – четырехузловой пластин-
чатый элемент (рис. 7). 

Этот элемент наиболее общий элемент для моделирования пластин, 
оболочек и мембран. CQUAD4 позволяет моделировать плоское напря-
женное состояние, изгиб, поперечный сдвиг в зависимости от данных, за-
даваемых в свойствах пластины (PSHELL-свойства). Этот элемент со-
единяется с другими элементами в четырех узлах. Номера узлов от G1 до 
G4 расположены последовательно по периметру элемента. Параметры 
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MCID и THETA (ориентация свойств материала элемента) не задаются 
для гомогенных и изотропных материалов. Параметров ZOFFS (смеще-
ние от поверхности узлов до поверхности расположения системы коор-
динат) используется, когда элемент имеет смещение. От T1 до Т4 – тол-
щины элемента в угловых точках, если их не задавать, то толщина эле-
мента T постоянна. Все внутренние углы элемента должны быть меньше 
180°. Силы и напряжения определяются в координатной системе элемен-
та. Координатная система располагается следующим образом: 

• ось x элемента проходит посередине угла 2α, положительное на-
правление от G1 к G2; 

• ось y элемента перпендикулярна к оси x и располагается в плоско-
сти G1, G2, G3, G4, положительное направление от G1 к G4; 

• ось z элемента нормальна к x − y плоскости элемента. Положитель-
ное направление z определяется по правилу правой руки, распола-
гая ее в порядке следования от G1 к G4. 

 
Рис. 7. CQUAD4-элемент и координатная система элемента 

Силы и моменты в CQUAD4 
В элементе возникает следующий набор силовых факторов (рис. 8): 
Fx , Fy –мембранные силы, приходящиеся на единицу длины; 
Fxy – мембранная сила сдвига на единицу длины; 
Mx , My – изгибающие моменты на единицу длины; 
Mxy – крутящий момент на единицу длины; 
Vx , Vy – поперечные силы на единицу длины. 
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Силы и моменты рассчитываются относительно цента масс элемента. На-
пряжения определяются на расстоянии z1 и z2 то плоскости расположе-
ния системы координат ( z1 и z2 задаются в свойствах элемента и указы-
ваются как поверхности, отстоящие от средней плоскости, т.е. z1 и  
 
 

Triangular Plate Element (CTRIA3) 
Этот элемент соединят три узловые точки. Элемент используется для 

согласования сеток элементов и заполнения нерегулярных границ. При-
менение этого элемента должно быть ограничено. Во многих аспектах 
этот элемент аналогичен CQUAD4. 

 

Рис. 8 Силовые факторы в элементе CQUAD4 
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Руководство к выполнению лабораторной работы 

Поскольку данная лабораторная работа выполняется в среде 
Nastran/Patran, то в первую очередь необходимо ознакомиться с последо-
вательностью решения инженерных задач с применением данных про-
граммных продуктов. 

Как уже было сказано выше, система MSC Patran используется как 
пре/постпроцессор, необходимый для формирования исходных данных 
поставленной задачи и обработки и представления результатов решения. 
В качестве решателя в данной работе используется система MCS Nastran, 
которая запускается непосредственно из интерфейса MSC Patran.  

Для того, чтобы решить инженерную задачу, используя систему 
MSC.Patran, необходимо выполнить три базовые стадии. Каждая из ста-
дий выполняется в соответствующих частях системы MSC.Patran. 

Первая стадия типичная и наиболее трудоёмкая по времени. Это 
создание геометрической модели объекта, которая должна включать в се-
бя: описание по форме и размерам, указание материалов из которых бу-
дет изготовлен реальный объект. Кроме этого необходимо задать внеш-
ние силы, действующие на объект. MSC.Patran имеет инструментарий, 
который помогает пользователю создать модель объекта с его внешними 
условиями. Используя этот инструментарий можно быстро создать двух-
мерную модель объекта. 

С помощью CAD-интерфейса можно импортировать и затем редак-
тировать геометрические модели объектов, созданных с помощью других 
программных продуктов. После создания геометрической модели, с по-
мощью мощных средств, имеющихся в системе MSC.Patran создаётся ко-
нечно-элементная модель объекта. К этим средствам относятся генерато-
ры конечно-элементных сеток, которые автоматически могут наноситься 
на кривые, поверхности и твёрдые тела, используя различные способы 
(Mapped And Paved Meshing). Допускается редактирование сетки конеч-
ных элементов в интерактивном режиме. MSC.Patran имеет возможность 
задавать свойства материалов, из которых изготавливается объект. Эти 
свойства определяют тип материала, жёсткость, плотность объекта моде-
лирования. При конечно-элементном анализе оценивается индивидуаль-
ные реакции модели на нагрузки и граничные условия. Нагрузки рас-
сматриваются в широком смысле и могут представляться в форме сил, 
моментов сил, давлений, температуры. 

Граничные условия описываются в терминах степеней свободы, ко-
торые определяют направление вдоль трёхмерных осей координат, по ко-
торым модель может или не может иметь перемещений, как в линейном, 
так и угловом направлениях. 

Вторая стадия заключается в анализе реакции конечной элементной 
модели с заданными граничными условиями на приложенные нагрузки. 
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Имеется ряд опций для запуска анализа конечно-элементной модели с 
помощью MSC.Patran. Можно использовать один из объектных кодов 
MSC: объектные коды других внешних программных продуктов или соб-
ственный код, созданный системой MSC.Patran. 

Далее необходимо определить тип конечного элемента (например, 
балка, стержень, пластина) и относящиеся к этому элементу свойства для 
различных областей вашей модели, например, если она выполнена из 
различных материалов, и назначить эти свойства конечным элементам 
модели. Тип элемента выбирается исходя из используемого объектного 
кода (он связан с используемым программным продуктом для проведения 
вычислений), конфигурации модели, предполагаемого поведения моде-
лируемого объекта (линейная или нелинейная). Дополнительные свойства 
описывают такие параметры как толщина пластины, коэффициент жёст-
кости пружины, площадь сечения балки и т.п. 

Анализ поведения объекта связан с проведением вычислительных 
операций по заданному алгоритму, который предоставлен той вычисли-
тельной системой, которая используется в данной задаче  (это могут быть 
NASTRAN, MARC, DYTRAN и т.п.). 

При выполнении этой стадии производятся следующие действия: 
• определяется требуемый алгоритм для решения задачи (тип инже-

нерной задачи, например, статический расчёт); 
• определяются и транслируются параметры, заданные для выполне-

ния задачи; 
• выбирается соответствующая схема или набор нагрузок (Load 

Cases); 
• выбираются переменные, требуемые для вывода после решения 
• задачи; 
• посылаются данные задачи для численного анализа в программу – 

вычислительную систему, используемую в данный момент решения 
задачи; 

• считываются количественные результаты из файлов результатов, 
созданных программой-вычислителем. 
Третья стадия заключается в трансляции (компиляции) результатов 

анализа и представление их в форме удобной для визуального анализа. 
Обычно численное решение задачи даёт большое количество цифровых 
данных, которые трудно анализировать, если выводить их в цифровой 
форме на бумагу. Поэтому на этой стадии используются возможности 
системы MSC.Patran для представления в визуальной форме данных, ис-
пользуя компьютерную графику, анимацию и другие предназначенные 
для этого инструменты. 

Данные, полученные в результате решения задачи, могут быть рас-
сортированы в зависимости от времени (временного шага), частоты, тем-
пературы или пространственного расположения по объёму анализа. Все 
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эти данные могут быть представлены в графической форме. Указанная 
последовательность выполнения инженерного анализа какого-либо про-
екта является типовой, но в процессе выполнения других проектов воз-
можны изменения указанной последовательности из-за конкретных тре-
бований или заданий. 

В качестве примера на рис. 9 приведена схема использования 
MSC.Patran совместно с вычислительной программой MSC.Nastran.  

 

Рис. 9. Блочная схема решения задачи с помощью системы MSC.Patran-
Nastran 
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Статический расчёт круглой пластины 

На этом примере подробно рассмотрим последовательность опера-
ций, которые нужно выполнить в среде MSC.Patran, чтобы подготовить 
модель для расчёта с помощью MSC.Nastran и затем вернуть результаты 
расчёта в среду MSC.Patran, чтобы их проанализировать. 

Описание задачи 
Круглая пластина имеет центральное концентрическое отверстие 

(рис. 10). Пластина поддерживается по внешнему контуру и нагружена по 
окружности радиуса r распределённой силой. В результате решения зада-
чи необходимо определить максимальные напряжения и прогиб. 

 

Рис. 10. Сечение заданной круглой пластины 

Геометрические размеры: 
a = 500 мм = 0,5 м 

b = 130 мм = 0,13 м 
r = 250 мм = 0,25 м 
t = 3 мм = 0,003 м 

Модуль упругости E = 0,689 ×105 МПа = 0,689 ×1011 Па. 
Коэффициент Пуассона ν = 0,3. 
Распределённая нагрузка q = 0,2 Н/мм = 200 Н/м. 
Поскольку данная задача является первой учебной задачей, то здесь 

приведено аналитическое решение, которое существует для такой про-
стой модели. 

Максимальные напряжения возникают на внешнем ребре и выража-
ются формулой: 

 
где максимальный прогиб: 

 
Подставив в формулы исходные данные и выразив их значения в 

системе СИ, получим: 
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σ = −66,04 ×106 Па = −66,04 МПа. 
ymax = 0,023 м =23 мм 

ния необходимо сравнить резуль-
таты

После получения машинного реше
. 
Концепция построения модели 
Физически пластина является твёрдым телом и может моделировать-

ся и е элементы, которые аппроксими-
руют

трачиваемые ресурсы вычисли-
тель

ов необходимо проводить инженерный анализ конструкции, перед 
тем 

лирования элементов, составляющих конструкцию, т.е. можно 
ли э

спользуя твёрдотельные конечны
 решение трёхмерной теории упругости. Концептуально, можно соз-

дать модель, имеющую от сотни до тысячи элементов, чтобы прибли-
зиться, таким образом, к точному решению. Если выполнить это решение 
и критически оценить результаты, то можно найти, что перемещения из-
меняются линейно при изменении толщины и что компоненты напряже-
ний по толщине очень плохо сопоставляются с компонентами напряже-
ний в плоскости пластины. С.Тимошенко и другие учёные уже сделали 
эти исследования и можно применить некоторые допущения, чтобы све-
сти трёхмерную задачу теории упругости к двумерной и рассматривать 
эту пластину как мембрану, модель, используемую для вычисления на-
пряжённого состояния в плоскости пластины. Двумерная аппроксимация 
напряжённого состояния материала, приводит к теории пластин, которая 
используется для оценки изгиба пластин. 

В данном примере будет использована аппроксимация пластины в 
виде мембраны, это позволит сократить за

ной машины и быстро получить решение. Если эти два обстоятельст-
ва несущественны, то можно осуществить построение трёхмерной моде-
ли. 

В заключение следует отметить, что в условиях ограниченных ре-
сурс

как создавать её модель, что позволит сократить размерность модели, 
уменьшить время решения и в некоторых случаях получить большую 
точность. 

При инженерном анализе конструкции принимается решение о спо-
собах моде

ти элементы рассматривать как балки, пластины, мембраны или же 
необходимо трёхмерное моделирование в виде твёрдотельных элементов. 

Разработка проекта задания 
Рекомендуется перед решением задачи составить проект задания, ко-

торы левой части указываются задания, ко-
торы

й состоит из двух колонок. В 
е являются основными для проекта, а в правой части указывается 

средства для подготовки решения задачи. 
Для того чтобы решить поставленную задачу необходимо выполнить 

эти одиннадцать пунктов. 
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Общую схему подготовки и решения задачи изобразим в виде ис-
пользуемых модулей (рис. 11), которые имеют такие же названия, как и 
панели инструментов основной панели MSC.Patran. 

 

Рис. 11. Схема подготовки модели, решение задачи, представления ре-
зультатов решения 

Первый пункт, касающийся задачи был уже выполнен. 
Второй пункт касается создания модели объекта, но поскольку мо-

дель будет создаваться в системе MSC.Patran, то для хранения элементов 
модели необходимо создать базу данных и присвоить ей имя. 

Создание новой базы данных 
В главном меню выбрать File > New. 
Появляется панель New > Database. 
Ввести в текстовое поле File Name имя базы данных: annular_plate и 

нажать Ok. 
Появится New Model Prference – панель для указания общих пара-

метров модели. В этой панели можно задать точность создания модели 
(Tolerance) или оставить значения по умолчанию (Default). 

Необходимо убедиться, что к системе MSC.Patran подключена вы-
числяющая программа MSC.Nastran, которая указана в разделе Analysis 
Code. Если имеется лицензия можно подключить другие программы. 

Выбрать в разделе Analysis Type > Structural и нажать Ok. 
База данных будет создана, но она будет пустая. 
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Разработка геометрического образа модели 
При рассмотрении концепции модели было принято решение созда-

вать модель с размерностью 2D, для этого будем использовать соответст-
вующие геометрические примитивы это кривая (Curve) и поверхность 
(Surface). Поверхность создадим путём поворота кривой на заданный 
угол (360°). Образующие линии будут задаваться по значениям коорди-
нат точек начала и конца кривой. Для того чтобы это осуществить необ-
ходимо сделать следующее:  

1. В главном меню выбрать кнопку Geometry. 
2. В появившейся панели выбрать Action > Create, Object > Curve 
и Method > XYZ. 
3. Ввести в окно ввода Vector Coordinate List координаты точки 3 

<0.120, 0, 0> и в окно Origin Coordinate List – начальную точку системы 
координат, координаты точки 1 <0.130, 0, 0>* и нажать Apply. Создаётся 
линия длиной 0,12 м в направлении оси x . 

4. Изменим Vector Coordinate List на <0.250, 0, 0>, чтобы построить 
координаты точки 2 в системе координат, которая имеет точку начала ко-
ординат Origin Coordinate List в точке 3 <0.25, 0, 0> и щёлкнуть Apply. 
Будет создана кривая №2 с радиусом внешней окружности пластины.  

Создание поверхности круглой пластины 
1. На панели Geometry изменить Object > Surface и Method > 

Revolve (поворот). 
2. Установить в окне Axis (ось координат, вокруг которой выполня-

ется Revolve) название оси z > 0.3, что означает номер системы коорди-
нат 0 (основная) и номер оси 3, т.е. ось z . 

3. В окно Sweep Parameters (пределы параметров) ввести Total 
Angle (общий угол поворота) > 90° и Offset Angle (угол смещения «угол 
пробела») > 0.0. Выделить изображения линий на экране, указав линию 1 
(curve 1). Нажать кнопку Apply. 

4. Чтобы создать поверхность 2 необходимо в окне панели Curve 
List указать линию 2 (curve 2) и нажать Apply. 

5. Необходимо создать другие поверхности, не выходя из этой пане-
ли, указав соответствующие линии, созданные другими поверхностями. 
Можно было бы создать поверхность за один поворот линий 1 и 2 на 
360°, но тогда не были бы получены диаметральные линии, которые нуж-
ны, чтобы сделать регулярную сетку конечных элементов.  

Создание поверхности с сеткой конечных элементов для Quad4 
1. В главном меню указать кнопку Elements. 
2. В верхней части появившейся панели выбрать Action > Create, 

Object > Mesh, Type > Surface. 
3. Настроить или проверить установку кнопок Element Shape 
(форма элемента) > Quad, Mesher (тип генератора сетки)> IsoMesh, 

Topology > Quad4 (четырёхузловой элемент). 
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4. Предварительно щёлкнув в окне Surface List (список поверхно-
стей) указать мышью на экране последовательно поверхности 1–8. В окне 
должна появиться надпись Surface 1:8. 

5. Ввести в окне Value (величина) цифру 0.050 в разделе Global Edge 
Length (глобальная длина ребра элемента). Снять маркер параметра 
Automatic Calculation (автоматическое вычисление) и нажать Apply. 

* В системе MSC.Patran все геометрические размеры задаются в мет-
рах 

6. Поскольку конечные элементы не соединены вдоль геометриче-
ских границ, то необходимо «сшить» их вместе. Для этого на верхней 
части панели Finite Element выбрать Action > Equivalence, Object > All, 
Method > Tolerance Cube (область допусков представляется кубом с реб-
ром 0,005 м). В пределах этой области все узлы будут объединяться в 
один. Нажать кнопку Apply. в строке сообщений внизу экрана будет ука-
зано сколько узлов было объединено (для данной задачи – 84 узла). 

Моделирование материала модели 
1. В главном меню, нажать кнопку Materials. В появившейся панели 

выбрать Action > Create, Object > Isotropic, Method > Manual Input 
(ручной ввод параметров материала). 

2. В окне Material необходимо набрать Aluminum. 
3. Нажать кнопку Input Properties (ввод свойств). 
4. Появится панель Input Options и в этой панели в строку Elastic 

Modulus ввести значение модуля упругости в Н/м2 – 0,689·1011; в строку 
Poisson Ratio (коэффициент Пуассона) – 0,3. Остальные строки можно не 
заполнять, так как они заполняются при решении динамических задач. 

5. Нажать Ok, чтобы закрыть панель и Apply на панели Materials. 
При этом свойства материала только выбраны, но не назначены на конеч-
ные элементы. 

Назначение (придание) элементам выбранных свойств материа-
ла и геометрии 

1. В главном меню нажать кнопку Properties (свойства). 
2. В появившейся панели Element Properties выбрать Action > 

Create, Object > 2D (двумерный), Type>Shell (группа элементов – обо-
лочка). 

3. В окно Properties Set Name (имя варианта свойств) ввести имя 
prop_1 или какое-либо другое. 

4. Нажать на кнопку Input Properties. 
5. На появившейся панели Input Properties, щёлкнуть мышкой в ок-

не Material Name и выбрать Aluminum в списке Material Properties Set. 
6. Ввести в окно Thickness (толщина) панели Input Properties вели-

чину 0,03 и нажать Ok. 
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7. На панели Element Properties поместить курсор в окно Select 
Members (Выбрать элементы) и затем курсором выбрать все поверхности 
на экране (или набрать Surface 1:8). 

8. Нажать кнопку Add (придать свойства), в окне Application Region 
должна повториться запись Surface 1:8. После этого необходимо нажать 
кнопку Apply. При этом заданные свойства будут назначены указанным 
конечным элементам. 

Моделирование нагрузок и граничных условий (LBC) 
Задание распределённых нагрузок. 
1. В главном меню нажать кнопку Loads/BCs. 
2. В появившейся панели Loads/Boundary Conditions выбрать Ac-

tion>Create, Object>Distributed Load (распределённая нагрузка), 
Type>Element Uniform (равномерная по элементу). 

3. В окно New Set Name ввести имя annular_load. 
4. Нажать кнопку Input Data (ввести данные). 
5. В появившейся панели Input Data в окно Edge Distributed Load 

(нагрузка, распределённая по ребру) ввести < , , –200>, что означает – на-
грузка задана против положительного направления оси z . Пробелы по 
направлениям осей x и y означают отсутствие нагрузок. Окно Edge 
Distributed Moment необходимо оставить пустым, т.е. нагрузка от мо-
ментов отсутствует. Нажать Ok. 

6. В панели Loads/BC нажать кнопку Select Application Region (вы-
брать область приложения нагрузок), в появившейся панели с этим же на-
званием под разделом Geometry Filter (геометрический фильтр) указать 
Geometry. Это означает, что нагрузки будут задаваться на геометриче-
ском образе модели, а не на конечно-элементном. 

Задавать нагрузки и граничные условия удобнее на геометрическом 
образе, т.к. конечных элементов на одном геометрическом элементе мо-
жет быть очень много и задавать нагрузку на каждый элемент трудоёмко. 
MSC.Patran перед расчётом автоматически перенесёт все нагрузки и гра-
ничные условия на соответствующие конечные элементы. 

7. В этой же панели поместить курсор в окно Select Surface Edge 
(выбрать ребро поверхности). Используя указатель мыши, выбрать четы-
ре ребра средних поверхностей, затем нажать Add. Номера выбранных 
рёбер поверхностей должны появиться в окне Application Region. Нажать 
Ok. 

8. Нажать кнопку Apply на панели Loads/BC. На экране должны 
появиться символы, обозначающие нагрузку (стрелки) и её величину 
(цифры возле стрелок). 
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Создание граничных условий 
В качестве граничного условия в задаче будет выступать 

Displacement (ограничение перемещений). 
1. В главном меню нажать кнопку Loads/BCs. 
2. В появившейся панели выбрать Action > Create, Object > Dis-

placement, Type > Nodal (узлы). 
3. В окно New Select Name ввести имя граничных условий pinned. 
4. Нажать Input Data (ввести данные). 
5. В появившейся панели в окно Translations (перемещения) ввести 

<0, 0, 0>, что означает запрет перемещений по осям x , y , z . Окно 
Rotations необходимо оставить пустым. Нажать Ok. 

6. Нажать кнопку Selection Application Region в панели Loads/BCs, 
после этого появится панель с таким же именем, в которой необходимо 
указать Geometry в разделе Geometry Filter. 

7. Поскольку в геометрической модели присутствую различные гео-
метрические сущности (Entities): рёбра, поверхности, вершины, то необ-
ходимо точно указать какие сущности будут ограничены по перемещени-
ям. Для этого в Select Menu (меню выбора) нажать кнопку Edge Option. 

Это означает, что на экране курсором мыши будут выделяться толь-
ко Edges (рёбра) геометрической модели. 

8. Поместить в окно Select Geometric Entities курсор, и используя 
указатель мыши выбрать на экране четыре ребра на внешних поверхно-
стях пластины. При выборе необходимо удерживать нажатой клавишу 
Shift, чтобы происходило суммирование выбора. Затем нажать Add и в 
окне Application Region должны появиться номера выбранных рёбер. 
Нажать Ok. 

9. На панели Loads/BCs нажать Apply. С помощью кнопок просмот-
ра изображений можно подобрать вид изображения для просмотра нагру-
зок и граничных условий. Граничные условия изображаются условными 
символами, около которых указываются номера ограниченных степеней 
свободы: 1, 2, 3, это означает, что ограничены перемещения по осям x , y , 
z . Вращательные степени 4, 5, 6 не указаны – значит, ограничений нет. 

Создание входного файла для MSC.Nastran 
Для каждой расчётной программы, которые могут быть использова-

ны вместе с MSC.Patran (их тип задаётся в Preference), создаются свои 
входные файлы. В данном случае рассмотрим создание файла для про-
граммы MSC.Nastran. 

1. В главном меню нажать кнопку Analysis. 
2. На появившейся панели выбрать Action > Analyze, Object > Entire 

Model, Method > Analysis Deck (метод брать с рабочего стола или панели 
управления). 

3. Нажать кнопку Solution Type (тип задачи). 
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4. В появившейся панели выбрать Linear Static (линейный статиче-
ский расчёт), нажать Ok.  

5. Нажать на кнопку Translation Parameters. В появившейся панели 
в разделе Data Output (вывод данных) нажать кнопку XDB and Print и в 
появившемся меню выбрать XDB Only (для сокращения размеров файла 
результата). Нажать Ok.  

6. Нажать кнопку Apply, чтобы запустить MSC.Nastran. На экране 
появляется окно MSC.Nastran с указанием размеров оперативной и дис-
ковой памяти, занятой под задачу, а также сообщение, что MSC.Nastran 
запущен, время и число. Через некоторое время, после окончания расчёта, 
окно пропадает. В строке сообщений можно прочитать сообщение о том, 
что трансляция входного файла была завершена успешно. 

Передача в среду MSC.Patran результатов решения задачи для 
обработки постпроцессором 

1. В главном меню нажать кнопку Analysis. 
2. На появившейся панели выбрать Action > Attach XDB, Object > 

Result Entities, Method > Local. 
3. Нажать на кнопку Select Results File. 
4. В появившейся панели найти и выделить annular_plate.xdb и на-

жать Ok. 
5. Нажать Apply на панели Analysis. 
Обработка результата постпроцессором 
Создание Fringe-изображения и деформированного изображения 

(Deformation Plot)  
1. В главном меню нажать кнопку Results.  
2. На появившейся панели выбрать Action > Create, Object > Quick 

Plot (быстрое изображение).  
3. В окне Select Result Cases панели Results выбрать Default, Static 

SubCase, в окне Select Fringe Result выбрать Displacement, Transla-
tional. 

4. В окне Select Deformation Result панели Results выбрать Dis-
placement, Translational . 

5. Нажать кнопку Apply. 
На экране появится изображение панели с цветной шкалой уровней с 

указанием максимальных и минимальных величин перемещений (проги-
бов). В результате решения задачи было получено максимальное переме-
щение равное 20,3 мм. 

6. Для того чтобы не мешало графическое изображение геометриче-
ской модели, необходимо убрать с экрана графику, нажав кнопку с изо-
бражением метлы (Reset Graphics), после этого нажать Apply на панели 
Results. 

7. Можно просмотреть форму деформации, воспроизведя «оживле-
ние» модели. Для этого нужно в окне Animate поставить скобку и нажать 
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Apply. Появляется окно, в котором указаны параметры анимации 
(скорость анимации). 

Передвигая движок можно регулировать скорость анимации. 

Содержание отчёта 

Отчёт по лабораторной работе должен содержать: 
• постановку задачи; 
• исходные данные (см. Приложение 4); 
• аналитическое решение задач; 
• сравнение результатов полученных аналитическим методом и с 

применением МКЕ; 
• выводы по работе. 
Задание выполняет группа студентов из 2 человек. Отчёт по проде-

ланной работе предоставляется индивидуально каждым учащимся. 
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Лабораторная работа «Статический расчёт твердо-
тельной детали с применением метода конечных эле-
ментов» 

Цель работы 

Цель данной практической работы состоит в том, чтобы на примере 
статического расчета круглой пластины ознакомиться: 

• с конечными твердотельными элементами; 
• с основами моделирования твердотельной геометрии в среде 

MSC.Patran; 
• с методикой моделирования поведения конструкции с применением 

твердотельных элементов; 
• со способами представления результатов моделирования. 
В результате выполнения лабораторной работы студенты должны 

приобрести навыки по компьютерному моделированию в инструменталь-
ной среде Nastran/Patran, которые они смогут применить на практике.  

Твердотельные элементы 

Твердотельные элементы являются трехмерными элементами и по-
зволяют моделировать поведение толстых пластин и тел. Основные твер-
дотельные элементы это шестисторонний CHEXA, пятисторонний 
CPENTA и четырехсторонний CTETRA. Твердотельные элементы соеди-
няются только по перемещениям, по вращательным степеням свободы 
эти элементы не соединяются.  

CHEXA – шестисторонний твердотельный элемент. Этот элемент 
рекомендуется применять для общего использования. Точность элемента 

уменьшается, когда элемент имеет сдвиг и используется в случае, 
когда изгибные деформации преобладают. В большинстве других ситуа-
циях использование этого элемента превосходит все другие 3D элементы. 
В CHEXA соединяются восемь узловых точек или до двенадцати узловых 
точек, если включить средние точки на ребрах. 

Напряжения элемента вычисляются в центре и также экстраполиру-
ются на угловые узлы.  

Геометрия элемента показана на рис. 12. Узловые точки от G1 до G4, 
соединенные последовательно, образуют четырехугольную плоскость. 
Узлы от G9 до G20 являются необязательными. Любой из них может 
быть удален. Угловые узлы не могут быть удалены.  

Компоненты напряжений σx , σ y , σz , σxy , σ yz , σzx выводятся в 
координатной системе, заданной для материала. Эта система определяет-
ся PSOLID-свойствами.  
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Рис. 12. Расположение узлов в CHEXA элементе 

Система координат для CHEXA показана на рис. 13. Оси координат 
этой системы обозначены как R , S , T , которые проходят через центры 
противоположных поверхностей. Начало координатной системы распола-
гается на пересечении осей координат.  

 

Рис. 13 Расположение системы координат для CHEXA элемента 

CPENTA – пятисторонний твердотельный элемент. Этот элемент ис-
пользуется для моделирования переходных зон от твердого тела к пла-
стинам или оболочкам. Если треугольные поверхности находятся не на 
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противоположных сторонах элемента, то можно получить его завышен-
ную жесткость.  

В этом элементе используется то 6 до 15 узловых точек. Напряжения 
вычисляются для центра и экстраполируются на угловые точки.  

CTETRA – четырехсторонний твердотельный элемент. Этот линей-
но-деформируемый элемент часто используется для заполнения круглых 
отверстий, которые появляются в моделях, выполненных из CHEXA  
элементов.  

В этом элементе соединяются четыре узла без средних узлов или до 
10 узлов со средними узлами. Напряжения вычисляются в середине эле-
мента и экстраполируются на угловые узлы. Геометрия показана на 
рис. 14.  

  

Рис. 14. Четырехсторонний CTETRA элемент 

Компоненты напряжений определяются и выводятся для анализа в 
системе координат материала элемента. Эта координатная система зада-
ется в свойствах элемента (PSOLID-строка в исполняемом файле). Коор-
динатная система состоит из трех векторов R , S , T , которые пересека-
ются в средних точках противоположных ребер (рис. 15). Начало коорди-
натной системы располагается в G1. 
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Рис. 15. Координатная система для CTETRA элемента 

Статический расчёт детали (LUG-проушина) 

Исходные данные 
E =2·105 Н/мм2 – модуль упругости Юнга для стали; 
ν =0,3 – коэффициент Пуассона. 
Нагрузка приложена к внутренним поверхностям отверстий на длине 

полуокружностей от точки a до точки b . нагрузка распределена по закону 

 
Деталь жёстко закреплена на неподвижном основании по площади A.  
Выполнить статический расчёт. Проанализировать напряжённо-

деформированное состояние, определив области, в которых напряжения 
превышают предел текучести σт=200 Н/мм2. Сформулировать предложе-
ние о величине допустимой нагрузки, которую можно приложить к от-
верстию. 
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Рис. 16. Аксонометрическая проекция детали (проушина) 

В данной задаче модель будет построена при помощи инструментов 
CAD-моделирования MSC.Patran.  

Создание новой базы данных 
1. В главном меню выбрать File > New. Появляется панель New 

Database. 
2. Ввести имя базы данных в окно Filename > Lug, Ok. 
3. Появляется панель New Model Preference. Убедиться, что 

MSC.Patran работает с MSC.Nastran и нажать Ok. 
Создание геометрической модели 
Рекомендуется перед тем, как создавать модель продумать план вы-

полнения операций, выполнение которых приведёт к результату. По-
скольку модель имеет прямоугольную форму, то основной заключитель-
ной операцией, после того как создана поверхность, будет операция 
Extrude по оси z. 
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Рис. 17. Эскиз детали и размеры 

Предлагается следующий план выполнения операций: 
1. Построить в плоскости YOX контур детали, который отражает 

конфигурацию боковой поверхности детали с учётом выреза. Построение 
осуществляется обычными средствами, используемыми при построении 
геометрических фигур (построение точек, линий, дуг окружностей, ок-
ружностей).  

2. После построения контура необходимо построить плоскости, при-
чём необходимо иметь две раздельные плоскости (или несколько плоско-
стей), которые позволят построить вырез. 

3. После построения вспомогательной плоскости детали в плоскости 
YOX системы координат осуществим операцию Extrude – передвинем 
плоскость ( a′ , b′ , 1, 2, b , a ) на расстояние 5 мм в направление осей z и 
−z . Таким образом построим часть детали, ограниченную сверху выре-
зом.  

4. Операцией Translate перенесём плоскости, соответствующие бо-
ковой поверхности детали на 5 мм по оси z и −z , а затем с помощью 
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Extrude передвинем их на 5 мм по оси z и −z , чтобы построить проуши-
ны (правую и левую). 

После таких операций твёрдотельная модель будет построена. 
Далее рассмотрим подробно все операции по созданию геометриче-

ской модели. Модель будет создаваться в единицах измерения – милли-
метрах. 

При задании свойства материала необходимо представить соответст-
вующие константы в мм. 

1. Ввести точки a[40 0 0], b[40 150 0], c[40 160 0] 
Geometry 
Action: Create 
Object: Point 
Method: XYZ 
В поле ввода вводить координаты точек, отметку Auto Execute не 

снимать. 
2. Построить точки a′ , b′ , c′ , для этого в панели Geometry заменить 
Action > Transform, Object > Point, Method > Translate. Установить 

в поле ввода Translate Vector <-80 0 0>, что означает перемещение точек 
по оси X на расстояние -80. В поле ввода Point List указать точки на эк-
ране, которые соответствуют точкам а, b , с. 

3. Построить контуры боковой поверхности детали путём соедине-
ния построенных точек. В панели Geometry, заменить Action > Create, 
Object > Curve, Method > Point; последовательно указывая на экране со-
единяемые точки, построить незамкнутую прямоугольную фигуру (по-
следовательность точек a , b; b , с; а, a′ ; a′ , b′; b′ , c′.)  

4. Построить дугу окружности радиусом 40 с центром в точке «О». В 
панели Geometry, выбрать Action > Create, Object > Curve, Method 2D 
Arc 2 Point. Указать в полях ввода центральную, начальную и конечную 
точки.  

5. Построить окружность радиусом 15мм. 
В панели Geometry, выбрать Action > Create, Object > Curve, 

Method > 2D Circle, в поле ввода Circle Radius задать радиус -15, указать 
центр дуги, предварительно поместив курсор в поле ввода Center Point 
List, и указав точку на экране.  

6. Чтобы построить точки 1 и 2 на окружности, необходимо провести 
линию b′ b известным способом, а затем найти точки пересечения окруж-
ности с этой линией. Для этого в панели Geometry выбрать Action > Cre-
ate, Object > Point, Method > Intersect, в полях ввода Curve List указать 
пересекаемые окружность и прямую линию, Apply.  

После получения точек пересечения ими необходимо разрезать пря-
мую линию, чтобы затем удалить средний сегмент 1-2 линии. В панели 
Geometry, Action > Edit, Object > Curve, Method > Break (сломать). В 
поле ввода Curve List указать окружность, а в поле ввода Break Point 
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List указать полученные пересечением окружности с линией b′ b точки, 
сначала одну, а затем другую. При этом на запрос Delete Original Curves 
(удалять первоначальные линии?) ответить утвердительно.  

7. Удалить сегмент 1–2 линии b′ b . На панели Geometry выбрать 
Action > Delete, Object > Curve и в поле ввода Curve List указать уда-
ляемый сегмент, Apply.  

8. Поскольку в дальнейшем необходимо строить поверхности, со-
стоящие из нескольких сегментов, то необходимо «разрезать» окруж-
ность точками 1 и 2. Выполняется это указанным выше способом, только 
в качестве кривой (Curve) указывается окружность. После выполнения 
этого действия окружность будет состоять из трёх сегментов.  

9. Чтобы получить нетриммированные поверхности проведём две 
вертикальные линии, соединяющие точки 1 и 2 с точками, которые будут 
располагаться на линии a′ a и которые нужно создать проецированием 
этих точек на прямую a′ a . Для этого в панели Geometry необходимо вы-
брать Action > Create, Object > Point, Method > Project (проецировать). 
В поля ввода Point List и Curve List ввести соответствующие точки и 
кривую a′ a , нажать Apply.  

10. Получив точки на прямой a′ a , её нужно «разрезать» на сегменты 
по этим точкам, для этого в панели Geometry, установить Action > Edit, 
Object > Curve, Method > Break и указать в поле ввода Curve List «раз-
резаемую» прямую, а в Break Point List точку «разрезания».  

11. Соединим три поверхности по двум линиям. В панели Geometry 
установить Action > Create, Object > Surface, Method > Curve. В полях 
ввода Starting Curve List ввести линии b′ 1 и указать сегмент, получен-
ный на ребре a′ a , нажать Apply. Повторить всё для сегмента 1–2 и для 
сегмента 2 b. 

12. Получим плоскости для верхней части фигуры выше линии b′ b . 
Предварительно нужно спроецировать точки c′ и c на окружность. 

Проекция точки c′ уже имеется, а проецирование точки c осуществляется 
уже известным способом. После проецирования точки c и получения её 
проекции на дуге, её необходимо разрезать этой точкой на сегменты. 

После этого необходимо создать три поверхности, указав линии: ду-
гу c′ c и дугу созданную спроецированными на внутреннюю окружность 
точками. Далее необходимо создать поверхности, определяемые отрезка-
ми c′ b′ , c b и противоположными сегментами окружности.  

Таким образом, проделав указанные операции, получена фигура, 
изображённая на рис. 18. На этом рисунке видны шесть отдельных по-
верхностей.  

13. В соответствии с чертежом необходимо создать четыре твёрдых 
тела путём «выдавливания» поверхностей по направлению оси z на соот-
ветствующие расстояния.  
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Поскольку построена только срединная поверхность, то сначала соз-
дадим два твёрдых тела, которые располагаются между проушинами пу-
тем Extrusion плоскостей 1,2,3 на 5 и -5 мм по оси z.  

В панели Geometry, Active > Create, Object > Solid, Method  > Ex-
trusion (выдавливание). В появившейся панели в поле ввода Translation 
Vector введём значения <0 0 5>, что означает перемещение по оси z на 5 
мм. В поле ввода Surface List необходимо ввести номера поверхностей 
путём указания курсором мыши по перемещаемым поверхностям (по-
верхности 1, 2, 3), нажать Apply.  

 

Рис. 18. Полученная фигура 

На запрос удаления первоначальных поверхностей отвечать отрица-
тельно.  

Повторить то же, только переместить поверхности по оси z на рас-
стояние <0 0 –5>. Таким образом, получены два твёрдых тела.  

14. Для того чтобы построить проушины необходимо сначала пере-
местить средние плоскости (6 штук) сначала на величину 5 мм, а затем –
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5мм. Это осуществляется в панели Geometry. В появившейся панели на-
строить Action > Transform, Object > Surface, Method > Translate. В 
появившейся панели в поле ввода Translation Vector указать <0 0 5> и в 
Surface List указать номера перемещаемых поверхностей (их шесть). То-
же повторить для <0 0 –5>. В данном случае при запросе на удаление 
первоначальных поверхностей нужно отвечать утвердительно.  

15. Построить по полученным поверхностям твёрдые тела (проуши-
ны) путём выдавливания этих поверхностей на величины их толщин. По-
сле выполнения операций получена фигура, изображённая на рис. 19.  

 

Рис. 19. Полученная фигура 

Можно удалить средний контур, используемый для построения, но 
сначала рекомендуется сохранить первоначальную модель в специальной 
группе (Group).  

В главном меню выбрать Group, в появившемся меню выбрать 
Create, нажать на эту запись, появится панель, в которой в поле ввода 
New Group Name ввести новое имя изображения модели, например gr1. 
затем в левой части найти меню фильтрации элементов и нажать на кноп-
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ку Solid, тем самым указав, что на экране курсор мыши будет выделять 
только Solids.  

В поле ввода Entity Selection (выбор геометрических элементов) 
ввести номера твёрдых тел, составляющих фигуру или деталь. Для этого 
поместить курсор в поле ввода и с помощью указателя мыши последова-
тельно указать на экране все твёрдые тела, предварительно придерживая 
кнопку Shift, чтобы в поле вводе происходило суммирование номеров 
твёрдых тел. По окончании нажать Apply.  

В главном меню нажать Group, в появившемся меню указать Post 
(просмотр). В появившейся панели в окне Select Groups to Post выделить 
только gr1 и нажать Apply. На экране появится изображение только твёр-
дых тел.  

Если нужно показать и то и другое можно выделить сразу два имени.  
Нанесение сетки конечных элементов на созданную модель 
Нажать кнопку Elements в появившейся панели выбрать Action > 

Create, Object > Mesh (сетка КЭ), Type > Solid, Elem > Shape (форма 
элемента) > Hex (прямоугольный элемент), Mesher (генератор сет-
ки)��Iso Mesh, Topology > Hex8 (восьмиугольный элемент).  

В поле ввода Solid List указать номера твёрдых тел (их должно быть 
18). Если не снимать скобку в окне Automatic Calculation, то в окне (ве-
личина) появится цифра, указывающая размер ребра элемента. Если на-
жать Apply, то произойдет нанесение сетки конечных элементов рис. 20.  

В окне Output ID List (список выходных данных) в поле Node ука-
зывается количество узлов, например 2793, а в поле Element – количество 
элементов, например 1033.  

После этого необходимо выполнить проверочные операции. 
Первая, «сжать» лишние узлы с помощью операции Equivalence. В 

панели указать Action > Equivalence, Object > All (все), Method > Toler-
ance Cube (поле допуска в форме куба). В поле Equivalencing Tolerance 
указан допуск – размер ребра куба, по умолчанию 0,005 мм. Далее нажать 
Apply. В строке сообщений появится надпись: Geometric equivalencing 
completed. 1172 nodes deleted. (операция завершена, 1172 узла удалено). 
Нажав на кнопку Refresh Graphics можно обновить изображение после 
удаления узлов. 

Эту операцию необходимо делать всегда, когда модель состоит из 
некоторого количества твёрдых тел несвязанных между собой. 

Следующей важной операцией является оптимизация матрицы жёст-
кости модели. Для этого установить Action > Optimize, Object > Nodes, 
Method > Both (оба метода оценки ширины ленты матрицы). Нажать 
Apply. 
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Рис. 20. Нанесенная сетка конечных элементов 

На экране появится таблица, в которой указаны размеры ширины 
ленты матрицы до сортировки Sorted FEM и после сортировки двумя ме-
тодами. Если сравнить цифры в правой последней колонке RMS 
Wavefront (среднеквадратическое значение ширины ленты), то можно 
заключить, что ширина ленты уменьшается после сортировки в 5–6 раз, 
или более. Таким образом, обеспечивается уменьшение машинного вре-
мени на решение задачи. Нажать Ok и после этого можно задавать на-
грузки, граничные условия, свойства элементам и т.п. для решения зада-
чи.  

Создание новой координатной системы 
1. Нажать в главном меню кнопку Geometry. 
2. В появившейся панели выбрать Action > Create, Object > Coord 

(координатная система), Method > 3Point (по трём точкам). 
3. Изменить в строке Coord ID List (список ID номеров координат-

ных систем) на 99, ввести Enter Origin [0 0 0], Point on the Axis 3 = [0 0 
1] и Point on Plane 1-3 (точка на плоскости 1-3) = [1 0 0]. Нажать Apply. 
Появится прямоугольная координатная система в точке O детали. 

Создание сетки конечных элементов под твёрдотельные элемен-
ты 

Будет использоваться элемент Tet10 (треугольная пирамида с 10 уз-
лами). 

1. В главном меню нажать кнопку Elements. 
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2. В появившейся панели выбрать Action > Create, Object > Mesh, 
Type > Solid. 

3. Изменить Global Edge Length на 0.005, выключив предварительно 
Automatic Calculation. 

4. Выбрать Tet Mesh в поле Mesher. 
5. В поле Topology выбрать Tet10. 
6. Поместить в поле ввода Input List курсор и выбрать твёрдотель-

ные элементы на экране, нажав левую кнопку мыши и не отпуская её, ок-
ружить прямоугольником модель на экране. В поле ввода должна поя-
виться надпись Solid 1 2. Нажать Apply. Когда на модели появиться сет-
ка, необходимо объединить рядом расположенные узлы твёрдотельных 
элементов. Для этого нужно выполнить Equivalencing.  

7. На верхней части панели Finite Elements выбрать Action > 
Equivalence, Object > All, Method > Tolerance Cube, нажать Apply. В 
строке сообщений будет указано, сколько узлов было удалено.  

Моделирование материалов 
1. В главном меню выбрать кнопку Materials.  
2. На появившейся панели выбрать Action > Create, Object > Iso-

tropic, Method > Manual Input. 
3. В строке Material Name панели набрать слово steel, потому что 

будут введены параметры материала, соответствующие стали. 
4. Нажать кнопку Input Properties на панели Materials. 
5. На появившейся панели Input Options заполнить строки под на-

званием Elastic Modulus и Poisson Ratio цифрами 2e11 и 0.3 соответст-
венно. 

6. Нажать Ok на панели Input Option и Apply на панели Materials. 
Назначение элементам их свойств 
1. В главном меню нажать кнопку Properties. 
2. В появившемся меню выбрать Action > Create, Object > 3D, 
Type > Solid. 
3. В строку Property Set Name ввести имя файла, например 
prop_1. 
4. Нажать на панели Element Properties кнопку Input Properties. 
5. Поместить в поле ввода Material Name курсор и выбрать steel из 

окна Material Property Set внизу панели Input Properties, в поле ввода 
Material Name появится запись m:steel. Нажать Ok.  

6. На панели Elements Properties поместить курсор в поле ввода 
Select Members выбрать на экране все элементы, имеющие заданные 
свойства и нажать Add. В окне Application Region должны появиться на-
звание элементов, например Solid 1 2.  

7. Нажать Ok, чтобы закрыть панель Input Properties и нажать 
Apply на панели Element Properties.  
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Создать PCL функцию, описывающую условия нагружения 
По условию задачи нагрузка, приложенная к проушине, распределя-

ется по закону 
15×103 × (x − 31,4)2 , Н/мм2

или 
15×109 × (x − 0,0314)2 Н/м2. 
1. В главном меню выбрать кнопку Fields. 
2. На появившейся панели выбрать Action > Create, Object > Spatial 

(пространство), Method > PCL Function (функция, записанная на PCL).  
3. В поле ввода Field Name набрать имя файла quadratic_loading 
или другое, выбрать под Field Type > Vector.  
4. Под разделом Coordinate System Type выбрать Real и ввести Co-

ord 99 в поле ввода Coordinate Systems.  
5. В поле ввода Second Component ввести уравнение 
15e9*(abs(‘x-0.0314)**2.0 
(убедитесь, что целое число 2 имеет десятичную точку). 
6. Нажать Apply. 
Моделирование нагрузок и граничных условий 
1. В главном меню нажать кнопку Loads/BCs. 
2. На появившейся форме выбрать Action > Create, Object > Force, 
Type > Nodal. В поле ввода New Set Name ввести имя contact_load 
или другое и нажать на кнопку Input Data.  
3. В появившейся панели Input Data поместить курсор в поле ввода 

Force (сила) и в окне Spatial Fields выбрать Quadratic_loading, нажать 
Ok.  

4. Нажать кнопку Select Application Region на панели Loading 
Boundary Conditions.  

5. В панели Select Application Region под разделом Geometry Filter 
выбрать Geometry.  

6. Поместить курсор в поле ввода Select Geometric Entities и, ис-
пользуя указатель мыши, выделить на экране проушину детали (место 
приложения к ней нагрузки) или напечатать Solid 2.3. Нажать Add и по-
том Ok.  

7. Нажать Apply на панели Loads/Boundary Condition. 
Задание граничных условий 
1. В главном меню нажать кнопку Loads/BCs. 
2. На появившейся форме выбрать Action > Create, Object > Dis-

placement, Type > Nodal. 
3. Ввести в поле New Set Name имя support. 
4. Нажать на кнопку Input Data. 
5. В появившейся панели в поле ввода Translations ввести <0, 0, 0>, 

что означает отсутствие перемещений по направлениям x , y , z , оставить 
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пустым поле ввода Rotations, что означает свободное вращение вокруг 
осей x , y , z , нажать Ok.  

6. Нажать кнопку Select Application Region. 
7. В появившейся форме под Geometry Filter выделить Geometry. 
8. Поместить курсор в поле Select Geometry Entities. Пользуясь ука-

зателем мыши выделить на экране нижнюю поверхность детали (места 
закрепления в пространстве), нажать Add и затем Ok.  

9. Нажать Apply в панели Loads/Boundary Conditions. 
Создание входного файла для решения задачи в MSC.Nastran 
Создание раздела(Bulk Data) во входном файле. 
1. В главном меню нажать кнопку Analysis. 
2. На появившейся панели выбрать Action > Analysis, Object > En-

tire Model, Method > Analysis Deck. 
3. Нажать на кнопку Solution Type (тип задачи). 
4. На появившейся форме выбрать Linear Static, так как по заданию 

необходимо выбрать статический расчёт, нажать Ok.  
5. Нажать Apply в форме Analysis. На экране появится окно про-

граммы MSC.Nastran с соответствующими сообщениями, через несколько 
секунд окно исчезнет, что означает конец работы программы 
MSC.Nastran.  

Передача результатов решения в MSC.Patran для их дальнейше-
го представления 

1. На панели Analysis выбрать Action > Attach XDB, Object > Result 
Entities, Method > Local. 

2. Нажать кнопку Results File. 
3. Выбрать в появившейся панели файл lug.xdb и нажать Ok. 
4. Нажать Apply на панели Analysis. 
Обработка результата постпроцессором 
Создание Fringe-изображения и деформированной модели. 
1. В главном меню нажать кнопку Results 
2. В появившейся панели выбрать Action > Create, Object > Quick 

Plot.  
3. В окне Select result Cases выбрать Default, Static Sub Case. 
4. В окне Select Fringe Result выбрать переменную в имеющемся 

списке, например, Stress Tensor (тензор напряжений).  
5. В окне Select Deformation Result выбрать Displacement, Transla-

tion, чтобы просмотреть перемещения.  
6. Нажать Apply. 
На экране появится цветное изображение распределения перемеще-

ний элементов деталей, т.е. её деформация.   
Для просмотра напряжений нужно выбрать Stress Von Mises. 
Просмотрев изображение необходимо найти наиболее деформируе-

мые части детали, оценить их величину. Выполнить отдельно расчёт де-

 56



формации прямоугольного стержня размером 100×50×20 при заданной 
суммарной нагрузке по формуле сопротивления материалов и сравнить с 
полученной в MSC.Nastran величиной. Объяснить разницу значений. 

Просмотрев изображение распределений напряжений по детали, 
найти максимальные напряжения, выполнить расчёт напряжений по фор-
муле сопротивления материалов для прямоугольной детали без проуши-
ны и сравнить величины. Объяснить разницу в величинах. 

Содержание отчёта 

Отчёт по лабораторной работе должен содержать: 
• постановку задачи; 
• исходные данные (приложение 5); 
• аналитическое решение задач; 
• сравнение результатов полученных аналитическим методом и с 

применением МКЕ; 
• выводы по работе. 
Задание выполняет группа студентов из 2 человек. Отчёт по проде-

ланной работе предоставляется индивидуально каждым учащимся. 
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Лабораторная работа «Построение 3D-моделей фор-
мообразующей оснастки» 

Цель работы 

Цель практической работы состоит в том, чтобы на примере по-
строения 3D-моделей деталей формообразующей оснастки в 
CAD/CAM/CAE-системе CATIA: 

• изучить методы и средства виртуального моделирования изделий в 
CAD/CAM/CAE-системе CATIA; 

• ознакомиться с технологиями виртуального моделирования необ-
ходимыми для решения задач проектирования сложной технологи-
ческой оснастки;  

• получить практические навыки создания 3D-моделей с помощью 
CAD/CAM/CAE- системы CATIA. 
В лабораторной работе будут рассмотрены отдельные возможности 

модуля Part Design (Проектирование деталей), предназначенного для про-
ектирования 3D-моделей деталей. 

Практическая работа проводится с использованием CAD/CAM/CAE-
системы CATIA. 

CAD/CAM/CAE-система CATIA 

Важнейшей современной тенденцией развития PLM-технологий яв-
ляется повышение роли 3D-моделей, их «смещение» от CAD/CAM и 
CAE-систем к PDM-системам и системам моделирования производствен-
ных процессов. Для этого необходимо обеспечить использование вирту-
альных моделей на всех этапах процесса проектирования и изготовления 
нового изделия, изменить само представление о работе технологических 
отделов, перевести ее на качественно новый уровень – PLM. Использова-
ние трехмерных моделей в работе технолога имеет своей целью не только 
упрощение чтения конструкторской информации, но и оптимизацию про-
цесса технологического проектирования.  На современных отечественных 
предприятиях инженеры-технологи зачастую оказываются исключены из 
процессов автоматизации, хотя на их долю приходится значительный 
объем проектных задач, таких как создание операционных заготовок, 
управляющих программ для станков с ЧПУ, технологических процессов. 

С помощью электронной модели изделия можно сократить время, 
затраченное на подготовку производства, повысить качество чертёжно-
конструкторской документации. Точная и актуальная информация дос-
тупна на любом уровне, каждая стадия разработок четко регламентирова-
на, и любой этап может быть своевременно проконтролирован. Всё это в 
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купе с использованием оборудования нового поколения, позволяет про-
изводить высокоточные сложнопрофильные изделия в максимально ко-
роткие сроки. 
CAD/CAM/CAE-система CATIA является неотъемлемой частью PLM ре-
шения:  

• CATIA обеспечивает основу для концептуальной разработки, опре-
деления изделия, его производства, моделирования и после про-
дажного обслуживания на различных этапах жизненного цикла из-
делия.  

• CATIA снабжает несколько этапов жизненного цикла специфика-
циями и геометрическими данными, связанными с изделием. 

CAD/CAM/CAE-система CATIA это программный комплекс проек-
тирования машиностроительных изделий. Представляет собой инстру-
менты параметрического твердотельного моделирования на основе при-
митивов. В CATIA можно создавать полностью ассоциативные 3D твер-
дотельные модели с ограничениями или без них, использующие автома-
тические или определяемые пользователем зависимости и обеспечиваю-
щие соответствие изделия техническому заданию на его проектирование. 

Проектирование деталей в CATIA осуществляется при помощи мо-
дуля Part Design. Part Design разработан в целях решения задач трехмер-
ного проектирования и конструирования деталей для всех отраслей ма-
шиностроения и обеспечения их использования для инженерного анализа, 
технологической подготовки производства, графического документиро-
вания и других задач машиностроительного предприятия. 

Модуль Part Design содержит мощные инструменты для проектиро-
вания трехмерных деталей, ассоциативные функции, основанные на эле-
ментах, и средство динамического построения эскизов. Позволяют поль-
зователям добавлять спецификации к создаваемым проектам как в про-
цессе работы, так и после завершения проектирования. Древовидная 
структура графически представляет организацию иерархии элементов, 
что позволяет ясно представлять влияние на проект вносимых в него из-
менений. В процессе изменения проекта пользователи могут выделять, 
копировать и добавлять целые группы элементов 

Работая в рамках машиностроительного проектирования, пользова-
тель CATIA может решать следующий круг задач: 

• твердотельное и каркасно-поверхностное моделирование деталей и 
сборочных единиц; 

• формирование чертежно-конструкторской документации; 
• простановка допусков и обозначений на модели с их контролем; 
• импорт моделей призматических деталей с восстановлением дерева 

компонентов; 
• проверка корректности и «лечение» импортируемой геометрии; 
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• проектирование формообразующих элементов пресс-форм и штам-
пов; 

• проектирование конструкции (пакетов) формообразующей оснаст-
ки; 

• конструирование изделий из листового металла; 
• проектирование сварных конструкций; 
• проектирование сборок на основе каталогов и пользовательских 

библиотек; 
• проектирование конструкций из листового металла в авиастроении; 
• проектирование деталей из композитных материалов с использова-

нием баз знаний; 
• функциональное проектирование изделий из пластмасс (т.е. с уче-

том их назначения, на соответствующем семантическом уровне). 
CAD-модели все чаще применяются наряду с чертежами. В PDM-

системах вместе с другой конструкторской информацией изделия сопро-
вождаются 3D-моделями. При реализации совместных проектов компа-
нии обмениваются электронными копиями, как чертежей, так и CAD-
моделей. На данный момент времени 3D-модели все шире применяются 
для обработки на станках с ЧПУ, быстрого прототипирования и автома-
тизированного контроля.  

Существенную часть ТПП составляет проектирование и изготовле-
ние средств технологического оснащения (пресс-формы, штампы, литей-
ные модели и формы), которые характеризуются сложными формами по-
верхностей и высокой трудоемкостью производства. В условиях отсутст-
вия автоматизации, длительный срок разработки формообразующей ос-
настки является одним из основных факторов, сдерживающих производи-
тельность ТПП. Использование системы CATIA обеспечивает высокое 
качество и значительное сокращение продолжительности процесса про-
ектирования и изготовления средств технологического оснащения. 

Все рассмотренные выше задачи по проектированию сложных изде-
лий и систем в CATIA решаются в трехмерном пространстве, на уровне 
виртуальных моделей. Таким образом, CATIA устраняет необходимость 
физического макетирования деталей и узлов для анализа их форм, компо-
новки, прочностных характеристик и т.д. Это экономит предприятию ма-
териальные ресурсы, сокращает время проектирования и подготовки про-
изводства изделий. В конечном счете, виртуальное макетирование снижа-
ет стоимость продукции предприятия и сокращает время выхода этой 
продукции на рынок. 
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Постановка задачи 

В данной лабораторной работе рассматривается система CATIA в 
рамках решения задачи автоматизации проектирования средств техноло-
гического оснащения. В процессе выполнения лабораторной работы не-
обходимо изучить модуль Part Design (Проектирование деталей) и по-
строить 3D-модели деталей формообразующей оснастки. В качестве ис-
ходных данные студентам предлагаются чертежи этих деталей (Прило-
жение 6). 

Руководство к проведению лабораторной работы 

Лабораторная работа проводится с использованием CAD/CAM/CAE 
системы CATIA. Поэтому для выполнения работы необходима предвари-
тельная установка данного программного обеспечения. Реализация рабо-
ты осуществляется на базе компьютерного класса кафедры ТПС.  

Внимание! Названия файлов создаваемых в системе CATIA 
должны вводиться латинскими буквами. 

Процесс проектирования 3D-моделей деталей состоит из следующих 
этапов:  

1. Создание новой детали.  
2. Выбор основания эскиза.  
3. Создание геометрии эскиза.  
4. Создание ограничений в эскизе.  
5. Создание 3D-примитива.  

1 Этап. Создание новой детали 

При создании новой модели автоматически активируется рабочая 
среда проектирования детали Part Design. Деталь сохраняется с расшире-
нием .CATPart, что отличает ее от других файлов CATIA.  

2 Этап. Выбор основания эскиза  

Документ CATIA состоит из отдельных элементов. Эти элементы 
получили название примитивы. Создавая документ можно добавлять та-
кие примитивы как призмы, карманы, отверстия, ребра, скругления и 
фаски. Как только примитивы созданы, они немедленно применяются к 
разрабатываемому изделию.  

По методу создания примитивы классифицируются: на основе эски-
зов (sketched-based) и вторичные (dress-up).  
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• Примитивы на основе эскизов строятся в 2D эскизе. Как правило, 
эскиз преобразуется в 3D тело в результате выдавливания, вращения, 
протягивания.  

• Вторичные примитивы создаются непосредственно на теле модели. 
Скругления и фаски являются примерами такого типа примитивов. 

CATIA графически отображает в дереве спецификации модели ее 
структуру на основе примитивов и другие не графические данные. Дерево 
спецификации показывает последовательность, в которой примитивы бы-
ли созданы, и обеспечивает легкий доступ ко всей ассоциированной ин-
формации и элементам, лежащим в основе этого примитива.  

Основание эскиза – это плоскость, в которой создается эскиз. Эскиз 
можно создать на вспомогательной плоскости или на плоской грани лю-
бой существующей геометрии. В документе любой детали первыми тремя 
примитивами по умолчанию являются вспомогательные плоскости. Имя 
каждой происходит от названия плоскости, которой она параллельна от-
носительно системы координат детали (XY, YZ, ZX). Вспомогательные 
плоскости обеспечивают плоскостную основу, на которой будет создан 
первый эскиз.  

3 Этап. Создание геометрии эскиза 

Создание каждой новой детали начинается с плоского контура в ра-
бочей среде построения эскиза Sketcher. Этот контур используется для 
построения трехмерных примитивов. Геометрия эскиза создается с по-
мощью инструментов, доступных в панели Profile (Контур): 

• User-Defined Profile  – определяемый пользователем контур. 

• Pre-defined Profiles  -предопределенные контуры.  

• Circles  – окружности.  

• Splines  – сплайны.  

• Ellipses  – эллипсы. 

• Lines  – прямые.  

• Axes  – оси.  
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• Points  – точки.  

Рекомендации к построению первоначального эскиза 
Первоначальную геометрию эскиза следует строить как можно бли-

же к форме и размерам окончательного ограниченного эскиза. Эскиз, 
сильно отличающийся от требуемого контура, будет деформироваться 
после применения к нему окончательных размеров. Это может затруд-
нить получение полностью ограниченного контура. 

Для модификации существующей геометрии эскиза необходимо ис-
пользовать панель инструментов операций Operation. 

4 Этап. Создание ограничений в эскизе 

На данном этапе необходимо добавить в эскиз размерные и геомет-
рические ограничения. Они служат для математического закрепления 
геометрии в пространстве координат. Без наложения ограничений соз-
данный примитив становится непредсказуемым и внесение в модель из-
менений может неблагоприятно сказаться на внешнем виде, компоновке 
и функционировании сборки в целом. Помимо этого ограничения исполь-
зуются для более точной связи геометрических элементов, позволяя соз-
давать между ними логические взаимосвязи. Ограничения добавляются в 
геометрию эскиза в рабочей среде Sketcher.  

Геометрически ограничения - ограничения, которые определяют 
расположение элементов эскиза относительно друг друга и относительно 
ранее созданной геометрии текущей модели.  

Размерные ограничения – ограничения, задающие расстояние между 
двумя элементами. В зависимости от типа участвующих в операции гео-
метрических элементов это расстояние может быть линейным, угловым 
или радиальным.  
Эти ограничения можно установить, используя иконки панели инстру-
ментов Constraint (Ограничения).  

Завершенный эскиз должен быть полностью ограничен. Размеры и 
положение эскиза должны быть точно заданы. Не полностью ограничен-
ный эскиз после модификации модели может не соответствовать услови-
ям. Зеленый цвет эскиза показывает, что эскиз полностью ограничен, 
геометрия фиксирована, и ее нельзя переместить без изменения значений 
размеров.  
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Ограничения в эскизе 

Ограничение Обозначение Описание 
Геометрические ограничения 

Fix (Фиксация) 

 

Фиксированный элемент 
нельзя модифицировать 

Coincidence (Совпаде-
ние)  

 

Выполняет совпадение точки 
элемента с другим элементом

Concentricity (Концен-
тричность)  

 

Делает две дуги концентрич-
ными 

Tangency (Касание) 

 

Устанавливает непрерывное 
касание между двумя эле-
ментами 

Parallelism (Парал-
лельность)  

 

Делает две прямые парал-
лельными. Для этого сначала 
необходимо выбрать пря-
мую, которая останется фик-
сированной, а затем -
прямую, которая будет па-
раллельна первой.  

Perpendicularity (Пер-
пендикулярность)  
 

 

Делает две прямые перпен-
дикулярными друг другу. 

Horizontal (Горизон-
тальность)  
  

Делает прямую горизонталь-
ной (параллельной оси H эс-
киза).  

Vertical (Вертикаль-
ность)  
 

 

Делает прямую вертикальной 
(параллельной оси V эскиза). 

Symmetry (Симметрия)  
 

 

Делает две прямые симмет-
ричными относительно вы-
бранного элемента. Для этого 
необходимо сначала указать 
две внешние прямые, а затем 
-элемент, относительно ко-
торого они должны быть 
симметричны. 

Размерные ограничения 
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Distance (Расстояние)  Вычисляется расстояние ме-
жду двумя элементами.  

Length (Длина)  

 

Вычисляется длина элемента, 
к которому применяется ог-
раничение.  

Angle (Угол)  

 

Вычисляется угол между 
двумя непараллельными 
прямыми.  

Radius/Diameter (Ради-
ус/Диаметр) 

 

Задается радиус или диаметр 
окружности или дуги 

5 Этап. Создание 3D-примитивов 

Важно начать работу над моделью с создания с устойчивого основа-
ния примитива. В дальнейшем модель детали будет формироваться путем 
добавления или удаления материала из этого начального примитива. 

При определении формы базового примитива рекомендуется выби-
рать базовые элементы, которые выражают первоначальную форму или 
функциональное назначение детали. Это не означает, что уровень детали-
зации для базового примитива должен быть полностью определен. На-
пример, такие примитивы как скругления, отверстия, карманы, фаски не 
обязательно создавать изначально как часть эскиза базового элемента де-
тали; они могут быть построены позже.  

Для выбора базового примитива необходимо.  
1. Определить конструктивные элементы детали.  
2. Выбрать один примитив, который станет базовым элементом дета-
ли.  
3. Определить инструменты CATIA, необходимые для построения 
примитивов.  
4. Построить примитив.  
Как только базовый примитив выбран, необходимо определить, в ре-

зультате какой операции будет формироваться тело добавления или уда-
ления материала.  
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Примитивы, которыми добавляется или удаляется материал:  

• Pad (Призма)  – материал добавляется в результате выдавли-
вания эскиза. 

• Shaft (Тело вращения)  – материал добавляется в результате 
вращения эскиза.  

• Rib (Ребро)  – ребра жесткости создаются  в результате вы-
давливания и придания толщины незамкнутому контуру эскиза.  

• Hole (Отверстие)   – отверстие образуется в результате уда-
ления материала цилиндрической формы из твердого тела. 

• Pocket (Карман)  – материал удаляется в результате выдавли-
вания эскиза. 

• Groove (Проточка)  – материал удаляется в результате враще-
ния эскиза.  

• Edge Fillet (Скругление)  – создается изогнутая грань постоян-
ного или переменного радиуса. 

• Chamfer (Фаска)  – удаляется или добавляется материал плос-
кого сечения на выбранном ребре. 

• Draft Angle (Уклон)  – назначается угловой наклон поверхно-
сти детали относительно некоторого ссылочного элемента. 

• Thread/Tap (Резьба)  – примитив определяет геометрию внут-
ренней и внешней резьбы. 

Повторно используемые примитивы 
CATIA позволяет создавать различные типы примитивов. Однако, 

существуют некоторые примитивы, которые многократно встречаются в 
модели. Чтобы не создавать каждый примитив отдельно, следует приме-
нить инструмент дублирования. Это позволит значительно сократить 
время на проектирование.  

Существует два вида инструмента дублирования: 
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1. Mirror (Зеркальное отражение) . 
С помощью инструмента Mirror можно созданную ранее одну полови-
ну симметричной детали продублировать в другой половине относи-
тельно вспомогательного элемента.  

2. Pattern (Массив) .  
Массивы позволяют создавать несколько одинаковых примитивов по 
одному ранее созданному и тут же указывать их положение в детали.  

Содержание отчета 

Отчёт по лабораторной работе должен содержать: 
1. Цель лабораторной работы. 
2. Исходные данные (см. Приложение 6). 
3. 3D-модель детали формообразующей оснастки. 
4. Выводы по проделанной работе. 

Лабораторная работа «Анализ технологических опе-
раций сборки в системе Delmia» 

Цель работы 

С помощью программного комплекса DELMIA DPM Assembly про-
анализировать столкновения компонентов сборки, рассмотреть различ-
ные варианты конфликтов и способы их устранения, ознакомиться:  

• c инструментами анализа геометрии системы DELMIA; 
• со способами решения проблемы соударения компонентов сборки; 
• с механизмом визуализации конфликтов. 

Постановка задачи 

Выполнение практической работы осуществляется в модуле DPM –
Assembly Process Simulation системы DELMIA V5.  

Для решения поставленной задачи необходимо использовать утили-
ты: 

• Analysis Tools. 
• Simulation Analysis Tools. 
• Data Views. 
• Player. 
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Необходимо выполнить ряд действий по анализу 3D-моделей в среде 
DELMIA V5: 

• Проанализировать дерево построения DELMIA V5, определить 
отношение указанных в задании параметров конкретным атрибутам 
примитивов системы. 

• Выполнить моделирование процесса сборки. 
• Произвести визуализацию собираемости сборки. 

Руководство по проведению лабораторной работы 

Данная лабораторная работа проводится с использованием 
CAD/CAM/CAE системы DELMIA. Поэтому для выполнения лаборатор-
ного практикума необходима предварительная установка данного про-
граммного обеспечения. Реализация работы осуществляется на базе ком-
пьютерного класса кафедры ТПС. 

Исходные данные для выполнения лабораторной работы:  
• 3D-модель сборки (3.5 HP engine) и модели рабочего места; 
• перечень технологических операций (последовательности сборки). 
На рис. 21 представлена модель двигателя, на примере которого не-

обходимо будет смоделировать процесс и провести анализ стоскновений 
его компонентов. 

 

Рис. 21. Исходные данные для анализа столкновений 

Перед началом выполнения работы требуется запустить DELMIA и 
перейти к модулю DPM Assembly Process Simulation (меню Start / Digital 
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Process for Manufacturing / Assembly Process Simulation) и открыть файл  
Simulation.CATProcess. 

Для анализа столкновений заданных компонентов сборки необходи-
мо выполнить следующую последовательность действий: 

1. Используя инструмент Restoring the initial state, восстановите 
исходное состояние сборки. 

2. При помощи утилиты Simulation Analysis выполните Clash 
Detection, выберите режим стоп. 

3. Запустите моделирование процесса сборки (Process Simalation) 
4. Активизируйте инструмент Clash Analysis, после появления диа-

логового окна, выберите режим анализа столкновений:  
• Contact + Clash; 
• Clearance + Contact + Clash; 
• Authorized penetration; 
• Clash rule. 

5. После выполнения анализа появиться диалоговое окно Check 
Clash, с результатами анализа. Сохраните полученные результа-
ты в файл.  

 

Рис. 22. Аналитический отчет столкновений 
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Для выбора анализа только между требуемыми компонентами, акти-
визируйте их при помощи инструмента Analysis Configuration (рис. 23). 

 

Рис. 23. Утилита Analysis Configuration 

Для просмотра всех компонентов сборки, можно использовать инст-
румент Explode, расположенный на панели Analysis Tools. Он позволяет 
разнести все детали сборки на некоторое предустановленное расстояние. 

Для отображения результатов анализа столкновений в дереве проек-
та необходимо  активировать атрибут Applicative data (Горизонтальное 
меню / Tools / Options / Digital Process for Manufacturing / Tree and activat-
ing).  

Содержание отчета 

Отчёт по лабораторной работе должен содержать: 
1. Цель лабораторной работы. 
2. Постановку задачи. 
3. Исходные данные (см. Приложение 7). 
4. Графическое изображение (в формате «*.bmp») момента 

столкновения компонентов. 
5. Отчет анализа столкновений в формате «*.xml». 
6. Выводы по проделанной работе. 
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Лабораторная работа «Управление перемещением 
компонентов сборки в системе Delmia» 

Цель работы 

С помощью программного комплекса DELMIA DPM Assembly задать 
траекторию перемещения компонентов сборки, рассмотреть различные 
варианты и способы реализации, ознакомиться: 

• c инструментарием создания траектории перемещения; 
• с временными ограничениями перемещения; 
• с механизмом визуализации сборочных операций. 

Постановка задачи 

Выполнение практической работы осуществляется в модуле DPM –
Assembly Process Simulation системы DELMIA V5. 

Для решения поставленной задачи необходимо использовать утили-
ты: 

• Simulation Activity Creation. 
• Simulation. 
• Recorder. 
• Manipulation 
• Player. 
Необходимо выполнить ряд действий по формированию траектории 

перемещения 3D-моделей в DELMIA V5: 
• Проанализировать дерево построения DELMIA V5, определить 

отношение указанных в задании параметров конкретным атрибутам 
примитивов системы. 

• Задать направления и траектории перемещения компонентов 
сборки. 

• Создать ряд пользовательских параметров. 
• Произвести визуализацию собираемости сборки. 

Руководство по проведению лабораторной работы 

Данная лабораторная работа проводится с использованием 
CAD/CAM/CAE системы DELMIA. Поэтому для выполнения лаборатор-
ного практикума необходима предварительная установка данного про-
граммного обеспечения. Реализация работы осуществляется на базе ком-
пьютерного класса кафедры ТПС. 

Исходные данные для выполнения лабораторной работы:  
• 3D-модель сборки (3.5 HP engine) и модели рабочего места; 
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• перечень технологических операций (последовательности сборки). 
3D-модели верстака и двигателя, представленные на рис. 24, являют-

ся исходными данными. 

 

Рис. 24. Исходные данные: виртуальное рабочее место 

Перед началом выполнения работы требуется запустить DELMIA и 
перейти к модулю DPM Assembly Process Simulation (меню Start->Digital 
Process for Manufacturing-> Assembly Process Simulation). Открыть файл  
Disassembly3.CATProcess. 

Для задания траектории перемещения компонента необходимо вы-
полнить следующую последовательность действий: 
2. Выделить операцию, для которой вы хотите задать перемещение. 

3. Создать перемещение с помощью инструмента Move Activity  и 
выбрать тип вставки “as child”. 

4. Убедиться, что в окне предварительного просмотра выбрана заданная 
деталь, нажать OK в окне Edit Shattle. 

5. Перетащить в виртуальном пространстве деталь в сторону от модели 
двигателя, используя компас. 

6. Зафиксировать положение, нажав кнопку Record  . 
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7. Повторить предыдущее действие, пока требуемая деталь не окажется 
на столе (рис. 25). 

 

Рис. 25. Перемещение детали 

8. Фиксировать каждое положение детали с помощью Record. 
9. Использовать панель инструментов Player для отмены или просмотра 

перемещений. 
10.  Убедиться, что деталь заняла необходимое положение (размещена на 

столе), закрыть диалоговое окно Track и повторить те же действия для 
прочих деталей в случае необходимости. 
После того, как траектории построены, можно посмотреть симуля-

цию всего процесса и определить места возникновения проблемных уча-
стков, представляющих собой столкновения компонентов и их взаимное 
пересечение. 

Перед созданием перемещения полезно скрыть неиспользуемые 
компоненты. Они останутся в дереве построения, но будут не видны на 
сборке (рис. 26).  

Для просмотра всех компонентов сборки, можно использовать инст-
румент Explode, расположенный на панели Analysis Tools. Этот инстру-
мент позволяет разнести все детали сборки на некоторое расстояние. 
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Время движения компонента можно редактировать.  Возможны ва-
рианты задания времени на перемещение либо задание скорости переме-
щения. Для этого надо выбрать More в диалоговом окне Track и задать 
требуемые параметры времени. 

 

Рис. 26. Настройка отображения компонентов сборки 

Содержание отчета 

Отчёт по лабораторной работе должен содержать: 
1. Цель лабораторной работы. 
2. Постановку задачи. 
3. Исходные данные (см. Приложение 8). 
4. Графическое изображение (в формате «*.bmp») результата 

перемещения.  
5. 3D-модель DELMIA V5 с результатом работы. 
6. Выводы по проделанной работе. 
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Лабораторная работа «Параметризация 3D-моделей 
изделий» 

Цель работы 

Цель практической работы состоит в том, чтобы на примере управ-
ления параметрическим описанием трехмерных моделей изделия в 
CAD/CAM/CAE системе CATIA:  

• познакомиться с технологией DMU (Digital Mock-Up); 
• освоить методы задания размеров и отношений на виртуальной мо-

дели изделия в виде связей и формул; 
• получить дополнительные навыки работы CAD/CAM/CAE системе 

CATIA; 
• познакомиться с существующими возможностями унификации и 

группирования изделий, получаемыми за счет использования со-
временных средств автоматизации. 

Практическая работа проводится с использованием CAD/CAM/CAE-
системы CATIA. 

Формулы и их реализация в CATIA 

Возможность управления цифровым описанием изделия в CATIA 
основывается на том, что каждый создаваемый элемент модели уникален 
и идентифицируется определенным набором параметров. Каждый из них 
характеризуется определенным типом, принимаемыми значениями и уни-
кальным именем. Состав параметров зависит от типа геометрического 
элемента. К параметризуемым элементам модели относятся не только 
размерные и геометрические ограничения (та информация, которая обыч-
но указывается на чертежах и эскизах), но и так называемы примитивы. 
Создание трехмерной модели изделия в CAD-системе происходит за счет 
построения последовательности примитивов, причем выделяют два их 
вида: 

• первичные примитивы (строятся на основе двухмерного эскиза; к 
ним относятся тела вращения, призмы и пр.); 

• вторичные примитивы (создаются непосредственно на теле модели; 
к ним относятся скругления, фаски, уклоны). 
Доступ к этим параметрам обеспечивается специальным сервисом – 

менеджером формул. 
Формула – это уравнение, которое накладывает определенные огра-

ничения на множество значений параметра, для которого она задается. 
Чаще всего формулой задается связь между различными параметрами. 

Формулы могут быть использованы для задания: 
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• управляющих размеров; 
• отношений; 
• примитивов. 
Управляющие размеры - это размеры, используемые для непосредст-

венного построения примитива. Они включают размеры, ассоциирован-
ные как с геометрией эскиза, так и собственно с примитивами. Рассмот-
рим, например, цилиндрическую призму. Диаметр призмы управляется 
диаметром окружности на эскизе, а ее высота - глубиной, на которую 
«выдавливается» эта окружность. 

Отношения включают в себя такую информацию, как параллель-
ность, касание, концентричность и др. Эти данные в CATIA устанавли-
ваются с помощью инструмента Constraint Definition и визуализируются 
на рисунке с помощью контрольных символов. 

Задание формул актуально для реализации в CAD некоторых иссле-
довательских технических задач, когда на модели необходимо задавать 
именно взаимосвязанные размеры. При таком подходе к проектированию 
упрощается реализация исследовательской (экспериментальной) части 
работы. Необходимые изменения можно отразить на модели, изменив 
значения лишь ключевых параметров. Все связанные размеры отредакти-
руются автоматически. Это актуально при проектировании сложных сис-
тем. 

Область применения формул (в CAD-системах) помимо исследова-
тельских задач распространяется на задачи унификации и группирования 
промышленных изделий, оптимизации многих технологических проце-
дур. Понятие комплексной детали, хорошо известное из курса «Техноло-
гии приборостроения», обретает новую практическую реализацию. 

Построение комплексной детали в CAD-системе основывается на 
использовании множества переменных, принимающих значения в соот-
ветствии с таблицей параметров. 

Постановка задачи 

Выполнение практической работы осуществляется в модуле Part De-
sign системы CATIA V5. 

Для решения поставленной задачи необходимо использовать утили-
ты: 

• Formulas. 
• Formula Editor. 
• Part Infrastructure (parameters, relation). 
• Parameter and Measure (parameter tree view). 
Необходимо выполнить ряд действий по параметризации 3D-

моделей CATIA V5: 
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• Проанализировать дерево построения CATIA V5, определить от-
ношение указанных в задании параметров конкретным атрибутам 
примитивов системы. 

• Переименовать задействованные в вычислениях параметры по-
строения. 

• Создать ряд пользовательских параметров. 
• В соответствии с заданием задать отношения между некоторыми 

параметрами в виде формул. 

Руководство по проведению лабораторной работы 

Данная лабораторная работа проводится с использованием 
CAD/CAM/CAE системы CATIA. Поэтому для выполнения лабораторно-
го практикума необходима предварительная установка данного про-
граммного обеспечения. Реализация работы осуществляется на базе ком-
пьютерного класса кафедры ТПС. 

Исходные данные для выполнения лабораторной работы:  
• чертежи деталей и таблицы исходных данных (Приложение 9); 
• 3D-модели деталей. 
Файлы с моделями деталей находятся в папке “Варианты заданий”, 

номер папки соответствует номеру варианта. 
Рассмотрим выполнение данного лабораторного практикума на при-

мере параметризации Вала 000.000.023 (рис. 27). 

 

Рис. 27. Вал 000.000.023 

В задании требуется: 
2. Переименовать следующие параметры: 

• обозначить длину ступени вала (20 мм, рис. 27) как параметр c; 
• обозначить диаметр вала (∅ 10) как параметр d; 
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2. Задать с помощью формул следующие геометрические ограниче-
ния: 

• диаметр вала b должен быть в два раза больше d; 
• длина ступени вала a должна быть на 8 мм длиннее c.  
Перед началом работы необходимо открыть в CATIA V5 3D-модель 

вала, указанного в задании (модуль Part Design).  

Настройка параметров системы 

В первую очередь необходимо откорректировать настройки CATIA 
V5 для установки опций отображения формул и параметров в дереве про-
екта. Для этого в горизонтальном меню системы необходимо выбрать: 
Tools > Options. В появившемся окне перейти к редактированию атрибу-
тов закладки Display (Options/Infrastructure/Part Infrastructure). После это-
го активировать опции Parameters и Relations. 

При активации атрибута Parameters в дереве проекта появляется 
папка с тем же именем, содержащая перечень всех параметров, создан-
ных пользователем в данном проекте. Соответственно при активации ат-
рибута Relations в дереве проекта в соответствующей паке выводятся все 
созданные формулы. 

Еще одной настройкой, влияющей на работу с параметрами, является 
опция Parameter Tree View (Options/ Parameter and Measure/’закладка’ 
Knowledge). Здесь возможно задать отображение пользовательских пара-
метров в дереве проекта с указанием его значения/значений (with value) и 
присоединенных формул (with formula). 

Переименование параметров 

После настройки параметров рабочей среды необходимо перейти не-
посредственно к работе с формулами. Согласно первому заданию необ-
ходимо переименовать некоторые параметры модели. По умолчанию в 
CATIA V5 размеры имеют сложные обозначения, с которыми достаточно 
неудобно работать. Поэтому параметры построения, используемые при 
создании форму, целесообразно переименовывать. Выполняется это сле-
дующим образом (рис. 28): 

• Запустить менеджер формул (Formula): выбрать иконку Formula на 
панели инструментов или в горизонтальном меню (Tools > 
Formula). 

• После загрузки окна Formulas указать 3D-элемент вала, для которо-
го существует искомый размер. 

Примечание! Если искомый размер не был явно задан при построении эс-
киза, он не будет отображен в списке параметров модели (Formulas). 
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• Указать на 3D-модели параметр, обозначение которого планируется 
изменить (в данном случае длину ступени вала 20 мм). 

• Изменить текущее имя параметра (например, Part-
Body\Shaft.1\Sketch.5\Length.16\Length) в строке ввода Edit name of 
the current parameter на заданное (например, c). 

• Нажать клавишу Apply (применить). 

 

Рис. 28. Менеджер формул CATIA V5 

Создание пользовательских параметров 

Согласно второй части задания необходимо связать некоторые гео-
метрические параметры вала формулами. Для этого в первую очередь 
следует создать соответствующие пользовательские переменные (пара-
метры). В данном случае a и b. Выполняется это следующим образом: 

• Запустить менеджер формул (Formula): выбрать иконку Formula на 
панели инструментов или в горизонтальном меню (Tools > 
Formula). 

• После загрузки окна Formulas нажать клавишу New parameter of 
type; система создаст пользовательскую переменную. После этого 
необходимо задать имя параметра, тип и значение и зафиксировать 
эти изменения с помощью клавиши Apply. 

Примечание! Для завершения работы с менеджером формул обязательно 
необходимо использовать клавишу ОК, иначе все произведенные дейст-
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вия не сохранятся (даже, если во время работы использовалась клавиша 
Apply). 

Создание формул 

Создание формул включает два этапа: 
• Установление соответствия между конкретными размерами детали 

и пользовательскими параметрами. 
• Создание геометрических ограничений согласно поставленной за-

даче. 
Примечание! При создании формул рекомендуется использовать именно 
пользовательские параметры. Установление размерных связей непосред-
ственно между размерами ограничит возможности пользователя по ре-
дактированию полученной параметрической модели. 

Назначить переменную на какой-либо размер можно следующим об-
разом: 

• Запустить менеджер формул (Formula). 
• После загрузки окна Formulas указать 3D-модель параметризуемой 

детали. 
• Выделить искомый размер (для рассматриваемого примера это c 

или d). 
• Нажать клавишу Add Formula в менеджере формул (система акти-

вирует меню Formula Editor, где выделенному размеру можно при-
своить арифметическое выражение). 

• В появившемся окне (рис. 29) выбрать (созданную ранее) перемен-
ную, с помощью которой планируется управлять редактируемым 
размером (например, длине ступени вала присваивается параметр a, 
рис. 27). 

• Завершить работу менеджера формул, нажав клавишу ОК для For-
mula Editor и Formula. 
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Рис. 29. Механизм создания формул в CATIA V5 

Создание геометрических ограничений производится аналогично с 
назначением переменной на размер. При этом в строке ввода в Formula 
Editor пользователем записывается арифметическое выражение, соответ-
ствующее условию конкретной задачи. Например, для выполнения требо-
вания «длина ступени вала a должна быть на 8 мм длиннее c», формула 
будет выглядеть следующим образом: 

8a c mm= + , 
где a - переменная, соответствующая длине одной из ступенек вала, 

а c – длина другой ступеньки (переименованный параметр).  
Примечание! При задании значений пользовательских переменных и при 
создании форму необходимо помнить, что в CATIA V5 любой размер по 
умолчанию имеет размерность метры. Для избежания ошибок построе-
ния необходимо явно указывать размерности используемых параметров. 

Следует отметить, что с помощью формул могут быть заданы не 
только численные величины, но и логические, имеющие значения 
true/false. 
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Содержание отчета 

Отчёт по лабораторной работе должен содержать: 
1. Цель лабораторной работы. 
2. Постановку задачи. 
3. Исходные данные (см. Приложение 9). 
4. Демонстрации с расширением 3dxml. 
5. 3D-модели CATIA V5 с результатом работы. 
6. Выводы по проделанной работе. 
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Приложение 1. Чертежи для выполнения заданий 

Вариант 1 
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Вариант 1 
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Вариант 2 
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Вариант 3 
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Вариант 3 
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Вариант 4 
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Вариант 4 
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Вариант 5 
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Вариант 5 

 

 92



Вариант 6 
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Вариант 6 
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Приложение 2. Варианты заданий 

Вариант 1 

Диаметр Магнита поз. 3 должен соответствовать внутреннему диаметру 
Втулки поз. 2 
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Вариант 2 

Диаметр Вала поз. 3 должен соответствовать внутреннему диаметру 
Корпуса поз.1 
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Вариант 3 

Диаметр Вкладыша поз. 1 должен соответствовать внутреннему диамет-
ру Втулки поз. 2 

 

 97



Вариант 4 

Ширина Прокладки поз. 3 должна соответствовать расстоянию между 
Магнитом поз. 1 и Наконечником поз. 2. 
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Вариант 5 

Ширина Шайбы поз. 5 должна быть равна расстоянию между Втулкой 
поз. 3 и  Втулкой поз. 3 
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Высота и ширина Заглушки поз. 3 должны соответствовать высоте и ши-
рине Трубки поз. 3 
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Вариант 6 

 
 



Приложение 3. Варианты заданий для самостоятельного выполнения 

Вариант 1 
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Вариант 2 
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Вариант 3 
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Вариант 4 



Вариант 1 

Задание: 
1. Измерить расстояние между элементами – построить размеры:  

• a,  b, с, d, e и f  произвольным образом; 
• g и h  в виде цепочки размеров; 
• i, j и k от общей базы. 

2. Измерить элементы – получить значение: 
• площади поверхности m; 
• длины окружности n.  

3. Получить следующие характеристики  детали: 
• массу детали; 
• координаты центра масс детали. 

Вариант 2 

Задание: 
1. Измерить расстояние между элементами – построить размеры:  

• a,  b, с и d произвольным образом; 
• e, f и g  от общей базы; 
• h, i и j в виде цепочки размеров. 

2. Измерить элементы – получить значение: 
• площади поверхности k; 
• периметра паза m.  

3. Получить следующие характеристики  детали: 
• массу детали; 
• плотность детали. 

Вариант 3 

Задание: 
1. Измерить расстояние между элементами – построить размеры:  

• a,  b, с и d произвольным образом; 
• e, f и g  в виде цепочки размеров; 
• h, i и j от общей базы. 

2. Измерить элементы – получить значение: 
• площади поверхности k; 
• длины дуги m.  

3. Получить следующие характеристики  детали: 
• массу детали; 
• плотность детали. 
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Вариант 4 

Задание: 
1. Измерить расстояние между элементами – построить размеры:  

• a,  b, g, h, n произвольным образом; 
• с, d , e, f  в виде цепочки размеров; 
• i, j, k, m и l от общей базы. 

2. Измерить элементы – получить значение: 
• площади основания k; 
• периметра основания m.  

3. Получить следующие характеристики  детали: 
• массу детали; 
• координаты центра масс. 
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Приложение 4. Варианты заданий для самостоятель-
ного выполнения 

№ варианта a (mm) b (mm) r (mm) t (mm) 
1 500 130 250 3 
2 700 150 250 4 
3 800 180 250 5 
4 500 130 300 3 
5 700 150 300 4 
6 800 180 300 5 

Приложение 5. Варианты заданий для самостоятель-
ного выполнения 

№ вари-
анта 

a (mm) b (mm) c (mm) d (mm) e (mm) f (mm) 

1 30 40 200 80 160 140 
2 30 40 250 80 210 190 
3 40 50 250 100 200 170 
4 40 50 300 100 250 220 
5 20 30 200 80 170 165 
6 20 30 250 80 220 205 



Приложение 6. Варианты заданий для самостоятельного выполнения 

Вариант 1 
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Вариант 2 

 109



Вариант 3 
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Вариант 4 
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Вариант 5 
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Вариант 6 
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Приложение 7. Варианты заданий для самостоятель-
ного выполнения 

Для каждого из вариантов подразумевается задание в виде исход-
ных данных двух компонентов сборки (двигатель, рис. 21), которые не-
обходимо проанализировать на наличие столкновений. Ниже приведены 
название деталей сборки 3.5 HP engine для каждого варианта: 

№ вари-
анта Наименование деталей 

1 Intake Valve (впускной клапан), Carburetor (карбюратор) 

2 Air Filter (воздушный фильтр), Crankshaft (коленчатый 
вал) 

3 Piston (поршень), Piston Rod (поршневой шток) 
4 Cam (кулачок),  Crankcase (картер) 
5 Flywheel (маховик), Cover (крышка) 

Приложение 8. Варианты заданий для самостоятель-
ного выполнения 

В каждом варианте необходимо задать перемещение двух компо-
нентов сборки. Следующая таблица содержит наименования деталей 
двигателя (рис. 24) в соответствии с вариантом лабораторной работы.  

Вариант Наименования деталей 
1 Intake Valve (впускной клапан), Carburetor (карбюратор) 

2 Air Filter (воздушный фильтр), Crankshaft (коленчатый 
вал) 

3 Piston (поршень), Piston Rod (поршневой шток) 
4 Cam (кулачок),  Crankcase (картер) 
5 Flywheel (маховик), Cover (крышка) 

 

 



Приложение 9. Варианты заданий для самостоятельного выполнения 

Вариант 1 
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Вариант 2 
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Вариант 3 
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Вариант 4 



Вариант 1 

Задание: 
1. Обозначить радиус матрицы (которому на чертеже соответствует 

∅200) как параметр a. 
2. Установить ограничение высоты ступени (заданной на чертеже 

размером 50 мм, см. вид слева) как 1/2 от радиуса a. 
3. Создать пользовательский параметр b, равный 15°. 
4. Задать величину помеченных на чертеже углов равной переменной 

b. 
5. Создать пользовательские параметры с и d, равные соответственно 

3 и 4.  
6. Задать количество отверстий ∅15,5/∅6,7 равным переменной c. 
7. Задать количество отверстий М12-5Н6Н равным переменной d. 
8. Создать пользовательские параметры e и f , равные соответственно  

1 мм и 45°. 
9. Принять размеры помеченных на чертеже фасок равными e f×  

(катет фаски равен 1 мм, а угол наклона 45°). 
10.  Дезактивировать с использованием формул на 3D-модели детали 

отверстие ∅75,7. 

Вариант 2 

Задание: 
1. Обозначить толщину плиты как параметр a. 
2. Создать пользовательский параметр b, равный 15 мм. 
3. Задать величину помеченной на чертеже глубины паза равной пе-

ременной b, а длину этого паза (45 мм на чертеже, см. вид слева) в 
3 раза большей b. 

4. Создать пользовательский параметр c, равный 25°. 
5. Задать величину помеченных на чертеже углов равной переменной 

c. 
6. Создать пользовательский параметр d, равный 12 мм. 
7. Задать диаметр резьбы в отверстии, равным переменной d. 
8. Задать количество отверстий ∅16 равным переменной h. 
9. Создать пользовательские параметры f и g, равные соответственно  

2 мм и 45°. 
10.  Принять размеры помеченной на чертеже фаски равными f g×  

(катет фаски равен 2 мм, а угол наклона 45°). 
11.  Дезактивировать с использованием формул на 3D-модели детали 

три паза (R20, см. главный вид). 
 

 119



Вариант 3 

Задание: 
1. Создать пользовательский параметр a, равный 40 мм. 
2. Задать толщину матрицы равным переменной a. 
3. Установить диаметр матрицы (которому на чертеже соответствует 

размер 200 мм, см. вид слева) в пять раз большим a. 
4. Установить длину резьбы М12-5Н6Н в семи отверстиях равной 

следующему выражению: 2 8a ÷ + . 
5. Создать пользовательский параметр b, равный 2°. 
6. Задать величину уклона прямоугольного паза (37,5×59,6) равной 

переменной b. 
7. Переименовать обозначение ширины паза как c (см. чертеж). 
8. Создать пользовательский параметр d, равный 40°. 
9. Установить угол наклона фаски (заданной на чертеже 30°, см. 

главный вид), выполненной в канавке (см. главный вид и вид Б), 
равным следующему выражению: 10d − ° . 

10.  Задать количество пазов (R12,5) равным пользовательской пере-
менной e. 

11.  Задать радиус скругления стенок прямоугольного паза (37,5×59,6) 
равным пользовательской переменной f (6 мм). 

12.  Дезактивировать с использованием формул на 3D-модели детали 
семь отверстий М12-5Н6Н. 

13.  Создать пользовательский параметр g, равный 5 мм. 
14.  Установить величину радиусов скругления в отверстиях ∅16 и 

∅20 равной переменной g. 

Вариант 4 

Задание: 
1. Создать пользовательский параметр a, равный 21 мм. 
2. Задать указанный на чертеже диаметр отверстия (см. главный вид) 

a. 
3. Создать пользовательский параметр b, равный 20°. 
4. Установить величину наклона отверстия ∅21 равной переменной 

b. 
5. Установить величину наклона ступени (которой на чертеже соот-

ветствует размер 15°, см. главный вид) равной переменной b. 
6. Создать пользовательский параметр c, равный 4 мм. 
7. Установить диаметр четырех отверстий (помеченных на чертеже 

как 4 отв. ∅3,6, см. вид слева) равным переменной c. 
8. Переименовать обозначение высоты шибера как d (как указано на 

чертеже). 
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9. Установить ширину шибера (которой на чертеже соответствует 
размер 48 мм, см. вид слева) равной следующему выражению: 

. Переименовать обозначение этого размера как e. 3d c+ +
10.  Установить радиус сферического паза (которому на чертеже соот-

ветствует размер 24,33 мм, см. вид сверху) равным следующему 
выражению: . 2 0.33e ÷ +

11.  Создать пользовательский параметр f, равный 10°. 
12.  Установить величину уклонов на внешних диаметрах ∅18,3, 

∅24,9, ∅31,32 равной переменной f. 
13.  Дезактивировать с использованием формул на 3D-модели детали 

отверстие M10-5Н6Н. 
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В 2007 году СПбГУ ИТМО стал победителем конкурса инноваци-

онных образовательных программ вузов России на 2007–2008 годы. Реа-
лизация инновационной образовательной программы «Инновационная 
система подготовки специалистов нового поколения в области инфор-
мационных и оптических технологий» позволит выйти на качественно 
новый уровень подготовки выпускников и удовлетворить возрастающий 
спрос на специалистов в информационной, оптической и других высоко-
технологичных отраслях экономики. 
 

КАФЕДРА ТЕХНОЛОГИИ ПРИБОРОСТРОЕНИЯ 
 

Кафедра технологии приборостроения относится к числу ведущих 
кафедр института со дня его основания в 1931 году. Тогда она называлась 
кафедрой механической технологии и возглавлялась известным ученым в об-
ласти разработки инструмента профессором А.П. Знаменским. Позже она бы-
ла переименована в кафедру технологии приборостроения. 

За время своего существования кафедра выпустила из стен института 
более тысячи квалифицированных инженеров, более сотни кандидатов и 
докторов наук. В разные годы ее возглавляли известные ученые и педагоги 
профессора Николай Павлович Соболев и Сергей Петрович Митрофанов. 

Кафедра имеет выдающиеся научные достижения. Заслуженным 
деятелем науки и техники РСФСР, профессором С.П. Митрофановым 
были разработаны научные основы группового производства, за что он 
был удостоен Ленинской премии СССР. Методы группового 
производства с успехом применяются в промышленности и постоянно 
развиваются его учениками. Заслуженным изобретателем Российской 
Федерации Юрием Григорьевичем Шнейдером разрабатаны метод и 
инструментарий нанесения регулярного микрорельефа на 
функциональной поверхности. 

В настоящее время кафедра осуществляет выпуск специалистов по 
специальностям "Технология приборостроения" (инженер-технолог, 
инженер-технолог-менеджер, инженер-технолог по искусственному 
интеллекту в приборостроении) и "Системы автоматизированного 
проектирования" (инженер-системотехник). На кафедре ведется 
подготовка бакалавров, магистров, инженеров и аспирантов по 
названным специализациям силами семи профессоров и девяти 
доцентов. 
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	 чертежи деталей и таблицы исходных данных (Приложение 3); 
	 3D-модели деталей. 
	Файлы с моделями деталей находятся в папке “Варианты заданий”, номер папки соответствует номеру варианта. 
	Рассмотрим выполнение данного лабораторного практикума на примере измерения Угольника  000.000.011 (рис. 2). 
	  
	В задании требуется: 
	1. Измерить расстояние между элементами – построить размеры:  
	 a и b от общей базы; 
	 c, d и e  в виде цепочки размеров. 
	2. Измерить элементы – получить значение: 
	 площади плоскости f; 
	 площади поверхности g.  
	3. Получить следующие характеристики  детали: 
	 координаты центра масс цилиндра (4; 
	 координаты центра масс детали; 
	 массу детали; 
	 площадь поверхности детали. 
	4. Построить пользовательскую систему координат в центре масс цилиндра (4. 
	Перед началом работы необходимо открыть в CATIA V5 3D-модель детали (модуль Part Design).  
	Выбор элементов измерения, менеджер измерений 
	Для проведения измерений в CATIA V5 необходимо запустить менеджер измерений соответствующего типа. Для этого необходимо воспользоваться панелью инструментов Measure (рис. 1). 
	После чего требуется указать измеряемые объекты. В процессе выбора значок курсора показывает тип выделенного элемента. Распознаются следующие типы элементов (рис. 3): 
	 цилиндрическая поверхность; 
	 плоскость или плоская поверхность; 
	 центр окружности; 
	 линия; 
	 точка. 
	Это позволяет быть уверенным в том, что выбирается требуемый для измерения элемент. 
	Еще одним способом убедиться в правильности выбора элемента является конкретное указание типа выбираемого элемента. Это обеспечивается с помощью выпадающего меню (Selection mode) в окне режима менеджера измерений (рис. 4). 
	Менеджер измерений позволяет изменять тип и режим измерения, накладывать ограничения на вид выбираемых элементов (меню Selection mode или панель настроек Customize) и результат измерений (панель настроек Customize), создавать дополнительную геометрию (панель Create Geometry). Настройка Keep Measure регулирует процесс сохранения измерений в дереве проекта. 
	  
	Измерение расстояний между элементами 
	Как указывалось выше, существуют три режима данного типа измерений. Для выполнения первого пункта задания необходимо воспользоваться опциями «построение размеров от общей базы» (например, a и b) и «цепочкой» (например, c, d и e), рис. 4. Для того чтобы все размеры находились в одной плоскости, необходимо указывать в качестве элементов измерения ребра детали (расположенные в одной плоскости), а не целые поверхности. 
	Сложность вызовет построение размера e. Это связано с тем, то один из элементов измерения представляет собой цилиндрическую поверхность. Для построения размера в этом случае необходимо предварительно создать вспомогательную плоскость, параллельную основанию угольника и касающуюся цилиндрической поверхности (R6,5). Данную плоскость необходимо указать как последний элемент для измерения. 
	  
	По умолчанию, в отчете результатов измерений, публикуется кратчайшее расстояние между двумя элементами. Есть механизм регулирования результатов измерения. Например, для получения компонентов расстояния (то есть, расстояний в направлениях X, Y и Z) относительно координатной системы необходимо нажать Customize и выбрать опцию Components (компоненты расстояния). Компоненты расстояния отображаются в окне Results (результаты). 
	Измерение объекта 
	Функция Измерение объекта (Measure Item) позволяет измерять отдельные геометрические элементы. Для измерения объекта необходимо выполнить последовательность шагов. 
	 Нажать иконку Measure Item (Измерение объекта). 
	 Выбрать геометрический элемент, который необходимо измерить. 
	 Характеристики выбранного геометрического элемента отображаются на модели и 
	 в окне результатов. 
	 Для сохранения измерения необходимо выбрать опцию Keep Measure. 
	 Для завершения измерения нажать OK. 
	 Если была выбрана опция Keep Measure, измерение остается в модели и добавляется в дерево спецификации. 
	Таким образом, для построения размеров f и g достаточно указать соответствующие элементы на 3D-модели. 
	Меню Customize позволяет скорректировать выбор элементов. Для данного типа измерений Customize включает следующие разделы: точки, ребра, элементы окружности, поверхности, 3D-свойства. Назначая те или иные атрибуты в меню можно создать условия измерения. 
	Инерционно-массовые характеристики 
	Для вычисления инерционно-массовых характеристик 3D-объектов с помощью функции Measure Inertia (измерение инерции) необходимо выполнить следующее: 
	 Нажать иконку Measure Inertia. 
	 Выбрать PartBody в дереве спецификации. 
	 Посмотреть результаты в менеджере измерений. 
	На модели при этом будет отображаться центр  масс изделия. 
	Для редактирования состава результатов необходимо воспользоваться Customize. Для данного типа измерений Customize отображает все виды результатов, которые возможно получить при измерении (площадь, массу, координаты центра масс, момент инерции и другие характеристики). 
	Measure Inertia включает два режима работы: измерения в 2D и в 3D. Состав характеристик измерения при этом различается (рис. 5). 
	Построение дополнительной геометрии 
	Для построения любых дополнительных геометрических элементов с помощью инструмента Measure необходимо воспользоваться инструментом Creation Geometry. Данным инструментом можно воспользоваться, указав соответствующую кнопку в менеджере Measur (рис. 4). В зависимости от типа измерения системой для построения будет предложен различный состав дополнительных элементов. Например, при указании отрезка такими элементами будут точки на концах и в середине отрезка, а при выборе цилиндрического отверстия это могут быть как точка в центре масс цилиндра (Measure Item), так и дополнительная система координат в центре масс цилиндра (Measure Inertia). 
	То есть в соответствии с заданием для получения значений координат центра масс необходимо произвести построение этого элемента (Creation Geometry), а потом в его характеристиках уточнить конкретное значение координат по осям. 
	  
	Отчёт по лабораторной работе должен содержать: 
	1. Цель лабораторной работы. 
	2. Постановку задачи. 
	3. Исходные данные. 
	4. Параметры дерева построения Measur. 
	5. 3D-модели CATIA V5 с результатом работы. 
	6. Выводы по проделанной работе. 
	Замечание: для проведения некоторых измерений требуется выполнить дополнительные построения. 
	 Лабораторная работа «Статический расчёт круглой пластины с применением метода конечных элементов» 
	Цель работы 
	Элементы поверхностей 
	Рис. 6. Три модели, применяемые для описания свойств мембраны 
	Руководство к выполнению лабораторной работы 
	Содержание отчёта 
	Отчёт по лабораторной работе должен содержать: 
	 постановку задачи; 
	 исходные данные (см. Приложение 4); 
	 аналитическое решение задач; 
	 сравнение результатов полученных аналитическим методом и с применением МКЕ; 
	 выводы по работе. 
	Задание выполняет группа студентов из 2 человек. Отчёт по проделанной работе предоставляется индивидуально каждым учащимся. 
	 Лабораторная работа «Статический расчёт твердотельной детали с применением метода конечных элементов» 
	Цель работы 
	Отчёт по лабораторной работе должен содержать: 
	 постановку задачи; 
	 исходные данные (приложение 5); 
	 аналитическое решение задач; 
	 сравнение результатов полученных аналитическим методом и с применением МКЕ; 
	 выводы по работе. 
	Задание выполняет группа студентов из 2 человек. Отчёт по проделанной работе предоставляется индивидуально каждым учащимся. 
	Цель работы 
	CAD/CAM/CAE-система CATIA 
	 Постановка задачи 
	Руководство к проведению лабораторной работы 
	Лабораторная работа проводится с использованием CAD/CAM/CAE системы CATIA. Поэтому для выполнения работы необходима предварительная установка данного программного обеспечения. Реализация работы осуществляется на базе компьютерного класса кафедры ТПС.  
	Отчёт по лабораторной работе должен содержать: 
	1. Цель лабораторной работы. 
	2. Исходные данные (см. Приложение 6). 
	3. 3D-модель детали формообразующей оснастки. 
	4. Выводы по проделанной работе. 
	Лабораторная работа «Анализ технологических операций сборки в системе Delmia» 
	Цель работы 
	Постановка задачи 
	 Analysis Tools. 
	 Simulation Analysis Tools. 
	 Data Views. 
	 Player. 
	 Проанализировать дерево построения DELMIA V5, определить отношение указанных в задании параметров конкретным атрибутам примитивов системы. 
	 Выполнить моделирование процесса сборки. 
	 Произвести визуализацию собираемости сборки. 
	Руководство по проведению лабораторной работы 
	Данная лабораторная работа проводится с использованием CAD/CAM/CAE системы DELMIA. Поэтому для выполнения лабораторного практикума необходима предварительная установка данного программного обеспечения. Реализация работы осуществляется на базе компьютерного класса кафедры ТПС. 
	Исходные данные для выполнения лабораторной работы:  
	 3D-модель сборки (3.5 HP engine) и модели рабочего места; 
	 перечень технологических операций (последовательности сборки). 
	На рис. 21 представлена модель двигателя, на примере которого необходимо будет смоделировать процесс и провести анализ стоскновений его компонентов. 
	Перед началом выполнения работы требуется запустить DELMIA и перейти к модулю DPM Assembly Process Simulation (меню Start / Digital Process for Manufacturing / Assembly Process Simulation) и открыть файл  Simulation.CATProcess. 
	Для анализа столкновений заданных компонентов сборки необходимо выполнить следующую последовательность действий: 
	 Contact + Clash; 
	 Clearance + Contact + Clash; 
	 Authorized penetration; 
	 Clash rule. 
	  
	Для выбора анализа только между требуемыми компонентами, активизируйте их при помощи инструмента Analysis Configuration (рис. 23). 
	  
	Для просмотра всех компонентов сборки, можно использовать инструмент Explode, расположенный на панели Analysis Tools. Он позволяет разнести все детали сборки на некоторое предустановленное расстояние. 
	Для отображения результатов анализа столкновений в дереве проекта необходимо  активировать атрибут Applicative data (Горизонтальное меню / Tools / Options / Digital Process for Manufacturing / Tree and activating).  
	Содержание отчета 
	Отчёт по лабораторной работе должен содержать: 
	1. Цель лабораторной работы. 
	2. Постановку задачи. 
	3. Исходные данные (см. Приложение 7). 
	4. Графическое изображение (в формате «*.bmp») момента столкновения компонентов. 
	5. Отчет анализа столкновений в формате «*.xml». 
	6. Выводы по проделанной работе. 
	Цель работы 
	Постановка задачи 
	 Simulation Activity Creation. 
	 Simulation. 
	 Recorder. 
	 Manipulation 
	 Player. 
	 Проанализировать дерево построения DELMIA V5, определить отношение указанных в задании параметров конкретным атрибутам примитивов системы. 
	 Задать направления и траектории перемещения компонентов сборки. 
	 Создать ряд пользовательских параметров. 
	 Произвести визуализацию собираемости сборки. 
	Руководство по проведению лабораторной работы 
	Данная лабораторная работа проводится с использованием CAD/CAM/CAE системы DELMIA. Поэтому для выполнения лабораторного практикума необходима предварительная установка данного программного обеспечения. Реализация работы осуществляется на базе компьютерного класса кафедры ТПС. 
	Исходные данные для выполнения лабораторной работы:  
	 3D-модель сборки (3.5 HP engine) и модели рабочего места; 
	 перечень технологических операций (последовательности сборки). 
	3D-модели верстака и двигателя, представленные на рис. 24, являются исходными данными. 
	  
	Перед началом выполнения работы требуется запустить DELMIA и перейти к модулю DPM Assembly Process Simulation (меню Start->Digital Process for Manufacturing-> Assembly Process Simulation). Открыть файл  Disassembly3.CATProcess. 
	Для задания траектории перемещения компонента необходимо выполнить следующую последовательность действий: 
	2. Выделить операцию, для которой вы хотите задать перемещение. 
	3. Создать перемещение с помощью инструмента Move Activity   и выбрать тип вставки “as child”. 
	4. Убедиться, что в окне предварительного просмотра выбрана заданная деталь, нажать OK в окне Edit Shattle. 
	5. Перетащить в виртуальном пространстве деталь в сторону от модели двигателя, используя компас. 
	6. Зафиксировать положение, нажав кнопку Record   . 
	7. Повторить предыдущее действие, пока требуемая деталь не окажется на столе (рис. 25). 
	  
	8. Фиксировать каждое положение детали с помощью Record. 
	9. Использовать панель инструментов Player для отмены или просмотра перемещений. 
	10.  Убедиться, что деталь заняла необходимое положение (размещена на столе), закрыть диалоговое окно Track и повторить те же действия для прочих деталей в случае необходимости. 
	После того, как траектории построены, можно посмотреть симуляцию всего процесса и определить места возникновения проблемных участков, представляющих собой столкновения компонентов и их взаимное пересечение. 
	Перед созданием перемещения полезно скрыть неиспользуемые компоненты. Они останутся в дереве построения, но будут не видны на сборке (рис. 26).  
	Для просмотра всех компонентов сборки, можно использовать инструмент Explode, расположенный на панели Analysis Tools. Этот инструмент позволяет разнести все детали сборки на некоторое расстояние. 
	Время движения компонента можно редактировать.  Возможны варианты задания времени на перемещение либо задание скорости перемещения. Для этого надо выбрать More в диалоговом окне Track и задать требуемые параметры времени. 
	  
	Содержание отчета 
	Отчёт по лабораторной работе должен содержать: 
	1. Цель лабораторной работы. 
	2. Постановку задачи. 
	3. Исходные данные (см. Приложение 8). 
	4. Графическое изображение (в формате «*.bmp») результата перемещения.  
	5. 3D-модель DELMIA V5 с результатом работы. 
	6. Выводы по проделанной работе. 
	 Лабораторная работа «Параметризация 3D-моделей изделий» 
	Цель работы 
	Формулы и их реализация в CATIA 
	Постановка задачи 
	 Formulas. 
	 Formula Editor. 
	 Part Infrastructure (parameters, relation). 
	 Parameter and Measure (parameter tree view). 
	 Проанализировать дерево построения CATIA V5, определить отношение указанных в задании параметров конкретным атрибутам примитивов системы. 
	 Переименовать задействованные в вычислениях параметры построения. 
	 Создать ряд пользовательских параметров. 
	 В соответствии с заданием задать отношения между некоторыми параметрами в виде формул. 
	Руководство по проведению лабораторной работы 
	Данная лабораторная работа проводится с использованием CAD/CAM/CAE системы CATIA. Поэтому для выполнения лабораторного практикума необходима предварительная установка данного программного обеспечения. Реализация работы осуществляется на базе компьютерного класса кафедры ТПС. 
	Исходные данные для выполнения лабораторной работы:  
	 чертежи деталей и таблицы исходных данных (Приложение 9); 
	 3D-модели деталей. 
	Файлы с моделями деталей находятся в папке “Варианты заданий”, номер папки соответствует номеру варианта. 
	Рассмотрим выполнение данного лабораторного практикума на примере параметризации Вала 000.000.023 (рис. 27). 
	  
	В задании требуется: 
	2. Переименовать следующие параметры: 
	 обозначить длину ступени вала (20 мм, рис. 27) как параметр c; 
	 обозначить диаметр вала (( 10) как параметр d; 
	2. Задать с помощью формул следующие геометрические ограничения: 
	 диаметр вала b должен быть в два раза больше d; 
	 длина ступени вала a должна быть на 8 мм длиннее c.  
	Перед началом работы необходимо открыть в CATIA V5 3D-модель вала, указанного в задании (модуль Part Design).  
	Настройка параметров системы 
	В первую очередь необходимо откорректировать настройки CATIA V5 для установки опций отображения формул и параметров в дереве проекта. Для этого в горизонтальном меню системы необходимо выбрать: Tools > Options. В появившемся окне перейти к редактированию атрибутов закладки Display (Options/Infrastructure/Part Infrastructure). После этого активировать опции Parameters и Relations. 
	При активации атрибута Parameters в дереве проекта появляется папка с тем же именем, содержащая перечень всех параметров, созданных пользователем в данном проекте. Соответственно при активации атрибута Relations в дереве проекта в соответствующей паке выводятся все созданные формулы. 
	Еще одной настройкой, влияющей на работу с параметрами, является опция Parameter Tree View (Options/ Parameter and Measure/’закладка’ Knowledge). Здесь возможно задать отображение пользовательских параметров в дереве проекта с указанием его значения/значений (with value) и присоединенных формул (with formula). 
	Переименование параметров 
	После настройки параметров рабочей среды необходимо перейти непосредственно к работе с формулами. Согласно первому заданию необходимо переименовать некоторые параметры модели. По умолчанию в CATIA V5 размеры имеют сложные обозначения, с которыми достаточно неудобно работать. Поэтому параметры построения, используемые при создании форму, целесообразно переименовывать. Выполняется это следующим образом (рис. 28): 
	 Запустить менеджер формул (Formula): выбрать иконку Formula на панели инструментов или в горизонтальном меню (Tools > Formula). 
	 После загрузки окна Formulas указать 3D-элемент вала, для которого существует искомый размер. 
	Примечание! Если искомый размер не был явно задан при построении эскиза, он не будет отображен в списке параметров модели (Formulas). 
	 Указать на 3D-модели параметр, обозначение которого планируется изменить (в данном случае длину ступени вала 20 мм). 
	 Изменить текущее имя параметра (например, PartBody\Shaft.1\Sketch.5\Length.16\Length) в строке ввода Edit name of the current parameter на заданное (например, c). 
	 Нажать клавишу Apply (применить). 
	  
	Создание пользовательских параметров 
	Согласно второй части задания необходимо связать некоторые геометрические параметры вала формулами. Для этого в первую очередь следует создать соответствующие пользовательские переменные (параметры). В данном случае a и b. Выполняется это следующим образом: 
	 Запустить менеджер формул (Formula): выбрать иконку Formula на панели инструментов или в горизонтальном меню (Tools > Formula). 
	 После загрузки окна Formulas нажать клавишу New parameter of type; система создаст пользовательскую переменную. После этого необходимо задать имя параметра, тип и значение и зафиксировать эти изменения с помощью клавиши Apply. 
	Примечание! Для завершения работы с менеджером формул обязательно необходимо использовать клавишу ОК, иначе все произведенные действия не сохранятся (даже, если во время работы использовалась клавиша Apply). 
	Создание формул 
	Создание формул включает два этапа: 
	 Установление соответствия между конкретными размерами детали и пользовательскими параметрами. 
	 Создание геометрических ограничений согласно поставленной задаче. 
	Примечание! При создании формул рекомендуется использовать именно пользовательские параметры. Установление размерных связей непосредственно между размерами ограничит возможности пользователя по редактированию полученной параметрической модели. 
	Назначить переменную на какой-либо размер можно следующим образом: 
	 Запустить менеджер формул (Formula). 
	 После загрузки окна Formulas указать 3D-модель параметризуемой детали. 
	 Выделить искомый размер (для рассматриваемого примера это c или d). 
	 Нажать клавишу Add Formula в менеджере формул (система активирует меню Formula Editor, где выделенному размеру можно присвоить арифметическое выражение). 
	 В появившемся окне (рис. 29) выбрать (созданную ранее) переменную, с помощью которой планируется управлять редактируемым размером (например, длине ступени вала присваивается параметр a, рис. 27). 
	 Завершить работу менеджера формул, нажав клавишу ОК для Formula Editor и Formula. 
	  
	Создание геометрических ограничений производится аналогично с назначением переменной на размер. При этом в строке ввода в Formula Editor пользователем записывается арифметическое выражение, соответствующее условию конкретной задачи. Например, для выполнения требования «длина ступени вала a должна быть на 8 мм длиннее c», формула будет выглядеть следующим образом: 
	 , 
	где a - переменная, соответствующая длине одной из ступенек вала, а c – длина другой ступеньки (переименованный параметр).  
	Примечание! При задании значений пользовательских переменных и при создании форму необходимо помнить, что в CATIA V5 любой размер по умолчанию имеет размерность метры. Для избежания ошибок построения необходимо явно указывать размерности используемых параметров. 
	Следует отметить, что с помощью формул могут быть заданы не только численные величины, но и логические, имеющие значения true/false. 
	 Содержание отчета 
	Отчёт по лабораторной работе должен содержать: 
	1. Цель лабораторной работы. 
	2. Постановку задачи. 
	3. Исходные данные (см. Приложение 9). 
	4. Демонстрации с расширением 3dxml. 
	5. 3D-модели CATIA V5 с результатом работы. 
	6. Выводы по проделанной работе. 
	Задание: 
	1. Измерить расстояние между элементами – построить размеры:  
	 a,  b, с, d, e и f  произвольным образом; 
	 g и h  в виде цепочки размеров; 
	 i, j и k от общей базы. 
	2. Измерить элементы – получить значение: 
	 площади поверхности m; 
	 длины окружности n.  
	3. Получить следующие характеристики  детали: 
	 массу детали; 
	 координаты центра масс детали. 
	Задание: 
	1. Измерить расстояние между элементами – построить размеры:  
	 a,  b, с и d произвольным образом; 
	 e, f и g  от общей базы; 
	 h, i и j в виде цепочки размеров. 
	2. Измерить элементы – получить значение: 
	 площади поверхности k; 
	 периметра паза m.  
	3. Получить следующие характеристики  детали: 
	 массу детали; 
	 плотность детали. 
	Задание: 
	1. Измерить расстояние между элементами – построить размеры:  
	 a,  b, с и d произвольным образом; 
	 e, f и g  в виде цепочки размеров; 
	 h, i и j от общей базы. 
	2. Измерить элементы – получить значение: 
	 площади поверхности k; 
	 длины дуги m.  
	3. Получить следующие характеристики  детали: 
	 массу детали; 
	 плотность детали. 
	Задание: 
	1. Измерить расстояние между элементами – построить размеры:  
	 a,  b, g, h, n произвольным образом; 
	 с, d , e, f  в виде цепочки размеров; 
	 i, j, k, m и l от общей базы. 
	2. Измерить элементы – получить значение: 
	 площади основания k; 
	 периметра основания m.  
	3. Получить следующие характеристики  детали: 
	 массу детали; 
	 координаты центра масс. 
	 Приложение 4. Варианты заданий для самостоятельного выполнения
	Приложение 5. Варианты заданий для самостоятельного выполнения
	Приложение 7. Варианты заданий для самостоятельного выполнения 
	Приложение 8. Варианты заданий для самостоятельного выполнения 
	Приложение 9. Варианты заданий для самостоятельного выполнения 
	Задание: 
	1. Обозначить радиус матрицы (которому на чертеже соответствует (200) как параметр a. 
	2. Установить ограничение высоты ступени (заданной на чертеже размером 50 мм, см. вид слева) как 1/2 от радиуса a. 
	3. Создать пользовательский параметр b, равный 15(. 
	4. Задать величину помеченных на чертеже углов равной переменной b. 
	5. Создать пользовательские параметры с и d, равные соответственно 3 и 4.  
	6. Задать количество отверстий (15,5/(6,7 равным переменной c. 
	7. Задать количество отверстий М12-5Н6Н равным переменной d. 
	8. Создать пользовательские параметры e и f , равные соответственно  1 мм и 45(. 
	9. Принять размеры помеченных на чертеже фасок равными   (катет фаски равен 1 мм, а угол наклона 45(). 
	10.  Дезактивировать с использованием формул на 3D-модели детали отверстие (75,7. 
	Задание: 
	1. Обозначить толщину плиты как параметр a. 
	2. Создать пользовательский параметр b, равный 15 мм. 
	3. Задать величину помеченной на чертеже глубины паза равной переменной b, а длину этого паза (45 мм на чертеже, см. вид слева) в 3 раза большей b. 
	4. Создать пользовательский параметр c, равный 25(. 
	5. Задать величину помеченных на чертеже углов равной переменной c. 
	6. Создать пользовательский параметр d, равный 12 мм. 
	7. Задать диаметр резьбы в отверстии, равным переменной d. 
	8. Задать количество отверстий (16 равным переменной h. 
	9. Создать пользовательские параметры f и g, равные соответственно  2 мм и 45(. 
	10.  Принять размеры помеченной на чертеже фаски равными   (катет фаски равен 2 мм, а угол наклона 45(). 
	11.  Дезактивировать с использованием формул на 3D-модели детали три паза (R20, см. главный вид). 
	Задание: 
	1. Создать пользовательский параметр a, равный 40 мм. 
	2. Задать толщину матрицы равным переменной a. 
	3. Установить диаметр матрицы (которому на чертеже соответствует размер 200 мм, см. вид слева) в пять раз большим a. 
	4. Установить длину резьбы М12-5Н6Н в семи отверстиях равной следующему выражению:  . 
	5. Создать пользовательский параметр b, равный 2(. 
	6. Задать величину уклона прямоугольного паза (37,5×59,6) равной переменной b. 
	7. Переименовать обозначение ширины паза как c (см. чертеж). 
	8. Создать пользовательский параметр d, равный 40(. 
	9. Установить угол наклона фаски (заданной на чертеже 30(, см. главный вид), выполненной в канавке (см. главный вид и вид Б), равным следующему выражению:  . 
	10.  Задать количество пазов (R12,5) равным пользовательской переменной e. 
	11.  Задать радиус скругления стенок прямоугольного паза (37,5×59,6) равным пользовательской переменной f (6 мм). 
	12.  Дезактивировать с использованием формул на 3D-модели детали семь отверстий М12-5Н6Н. 
	13.  Создать пользовательский параметр g, равный 5 мм. 
	14.  Установить величину радиусов скругления в отверстиях (16 и (20 равной переменной g. 
	Задание: 
	1. Создать пользовательский параметр a, равный 21 мм. 
	2. Задать указанный на чертеже диаметр отверстия (см. главный вид) a. 
	3. Создать пользовательский параметр b, равный 20(. 
	4. Установить величину наклона отверстия (21 равной переменной b. 
	5. Установить величину наклона ступени (которой на чертеже соответствует размер 15(, см. главный вид) равной переменной b. 
	6. Создать пользовательский параметр c, равный 4 мм. 
	7. Установить диаметр четырех отверстий (помеченных на чертеже как 4 отв. (3,6, см. вид слева) равным переменной c. 
	8. Переименовать обозначение высоты шибера как d (как указано на чертеже). 
	9. Установить ширину шибера (которой на чертеже соответствует размер 48 мм, см. вид слева) равной следующему выражению:  . Переименовать обозначение этого размера как e. 
	10.  Установить радиус сферического паза (которому на чертеже соответствует размер 24,33 мм, см. вид сверху) равным следующему выражению:  . 
	11.  Создать пользовательский параметр f, равный 10(. 
	12.  Установить величину уклонов на внешних диаметрах (18,3, (24,9, (31,32 равной переменной f. 
	13.  Дезактивировать с использованием формул на 3D-модели детали отверстие M10-5Н6Н. 
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